Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unlocked att s3 is having reception issues on t-mobile

OP austinxo

27th May 2014, 11:25 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: May 2014
I constantly get very little to no reception on my S3. My 4g connection is constantly turning off and when it is working it is painfully slow. even have problems with the wifi being wishy washy. I consistently have problems sending and receiving text messages and at time calls fail to go through. I have a feeling it has to do with the phone being unlocked because my sister and father both have t-mobile S3's and they never have connection issues. I really have no idea where to start with resolving this issue.

Thanks
28th May 2014, 03:36 AM   |  #2  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 1,029
 
3,197 posts
Join Date:Joined: Jun 2012
More
The att s3 doesn't natively support was. The T-Mobile s3 is not the same model as the att s3.
30th May 2014, 04:03 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by audit13

The att s3 doesn't natively support was. The T-Mobile s3 is not the same model as the att s3.

My phone is unlocked
30th May 2014, 04:31 AM   |  #4  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 1,029
 
3,197 posts
Join Date:Joined: Jun 2012
More
I meant to say the ATT s3 (i747) does not natively support AWS which T-mobile does use. Usually, unlocking a phone will not affect reception.

BTW, my autocorrect changed "aws" to "was" in my previous post.

The T-mobile s3 is the T999 even though both phones are referred to as an s3.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes