Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,399 Members 52,141 Now Online
XDA Developers Android and Mobile Development Forum

Building CM11 for the z1, getting error.

Tip us?
 
ekanix20
Old
#1  
Senior Member - OP
Thanks Meter 104
Posts: 523
Join Date: Mar 2012
Location: Örebro
Default Building CM11 for the z1, getting error.

Hi everyone, i am trying to build my own CM 11.0 but i keep getting the same error.
Code:
Repository synced!
Looking for dependencies
Done
build/core/product_config.mk:238: *** _nic.PRODUCTS.[[device/sony/honami/cm.mk]]: "vendor/sony/qcom-common/qcom-common-vendor-330.mk" does not exist.  Stop.

** Don't have a product spec for: 'cm_honami'
** Do you have the right repo manifest?
I have tried googling but no luck so far
Would be very thankful if someone could help me.

Best regards.


Sent from my Xperia Z1 using Tapatalk
Phone: Xperia Z1

Bootloader: Unlocked
 
Barracuda77777
Old
#2  
Barracuda77777's Avatar
Senior Member
Thanks Meter 192
Posts: 561
Join Date: Jul 2011
Location: Sydney
Hey mate,

I used this guide to build and it worked:

http://forum.xda-developers.com/show...54&postcount=1


just replace the directory structure to the one that you have and it will work,
I repeated the following steps to download the files needed to each of my devices:

$ cd ~/bin
$ curl http://commondatastorage.googleapis....downloads/repo > ~/bin/repo
$ chmod a+x ~/bin/repo

then

cd to your main folder and then run the following command

$ repo init -u git://github.com/CyanogenMod/android.git -b cm-11.0

then
$ repo sync

then

$ . build/envsetup.sh

then hopefully when you run breakfast honami it should work.

good luck








Quote:
Originally Posted by ekanix20 View Post
Hi everyone, i am trying to build my own CM 11.0 but i keep getting the same error.
Code:
Repository synced!
Looking for dependencies
Done
build/core/product_config.mk:238: *** _nic.PRODUCTS.[[device/sony/honami/cm.mk]]: "vendor/sony/qcom-common/qcom-common-vendor-330.mk" does not exist.  Stop.

** Don't have a product spec for: 'cm_honami'
** Do you have the right repo manifest?
I have tried googling but no luck so far
Would be very thankful if someone could help me.

Best regards.


Sent from my Xperia Z1 using Tapatalk
 
ekanix20
Old
#3  
Senior Member - OP
Thanks Meter 104
Posts: 523
Join Date: Mar 2012
Location: Örebro
Quote:
Originally Posted by Barracuda77777 View Post
Hey mate,

I used this guide to build and it worked:

http://forum.xda-developers.com/show...54&postcount=1


just replace the directory structure to the one that you have and it will work,
I repeated the following steps to download the files needed to each of my devices:

$ cd ~/bin
$ curl http://commondatastorage.googleapis....downloads/repo > ~/bin/repo
$ chmod a+x ~/bin/repo

then

cd to your main folder and then run the following command

$ repo init -u git://github.com/CyanogenMod/android.git -b cm-11.0

then
$ repo sync

then

$ . build/envsetup.sh

then hopefully when you run breakfast honami it should work.

good luck
Thanks mate but I am already running my own build!

Skickat från min Xperia Z1 via Tapatalk
Phone: Xperia Z1

Bootloader: Unlocked
Thread Tools
Display Modes