Nvidia and Robotics w/ Barrett Williams – XDA:DevCon 2014

Robotics continues to dominate our videos from this years XDA:DevCon 2014 in … more

Speed Up Deodexing with JoelDroid Batch Deodexer

Android 5.0 Lollipop brings many under-the-hood changes like changing the default compiler … more

Top 5 Apps for 2014 + Top Xposed Mod of 2014 – XDA TV

Its that time of year where you look back and remember the things that happened … more

NVIDIA SHIELD Tablet Gets Android 5.0.1, OTA Available

The NVIDIA SHIELD Tablet is the latest Android-powered device released by famed GPU … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] bootloops problem after unlocking the boot loader and installing cwm

OP ramzwelath

31st May 2014, 10:41 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
2 posts
Join Date:Joined: May 2014
I unlocked the bootloader of my xperia m c1904 yesterday.and after that i flashed with cwm, after performing these steps i installed superusersu using cwm-installwinzip. after these steps i made a clean boot but my xperia m stuck at bootloop and when i tried to wipe data it showed error. cant do a factory reset too. cant mount data too. pls hep me. am new to xda and this is my first time rooting experience. any suggestion please.
thanks in advance.
31st May 2014, 12:37 PM   |  #2  
stalin.sk2's Avatar
Senior Member
Flag Madurai
Thanks Meter: 45
 
127 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by ramzwelath

I unlocked the bootloader of my xperia m c1904 yesterday.and after that i flashed with cwm, after performing these steps i installed superusersu using cwm-installwinzip. after these steps i made a clean boot but my xperia m stuck at bootloop and when i tried to wipe data it showed error. cant do a factory reset too. cant mount data too. pls hep me. am new to xda and this is my first time rooting experience. any suggestion please.
thanks in advance.

flash the stock firmware (here you have to wipe cache and data)

no need to unlock bootloader once again already unlocked

follow the root instructions step by step

don't wipe cache and data(it will erase all your user data)

before flashing or changes with cwm please take a complete backup its help you to revert your phone.
31st May 2014, 01:44 PM   |  #3  
Junior Member
Thanks Meter: 3
 
22 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by ramzwelath

I unlocked the bootloader of my xperia m c1904 yesterday.and after that i flashed with cwm, after performing these steps i installed superusersu using cwm-installwinzip. after these steps i made a clean boot but my xperia m stuck at bootloop and when i tried to wipe data it showed error. cant do a factory reset too. cant mount data too. pls hep me. am new to xda and this is my first time rooting experience. any suggestion please.
thanks in advance.

I had exactly the same experience (except that I didn't install supersu) with my Xperia M C1905 a few days ago, and have been struggling unsuccessfully to fix it. In my case the phone got stuck at the animated boot logo after I unlocked the bootloader, even though I used the official Sony method and followed the instructions to the letter, and it said it worked OK with no errors. After that I successfully flashed a CWM boot image, and can now boot into recovery, but normal boot is still stuck at the logo. I can access the phone with flashboot but not adb. I have the correct Windows 7 drivers installed.

In CWM I find (like the previous poster) that I cannot mount or format /data, so I assume that's the cause of the problem. Does this mean that the data partition has got corrupted? If so, how can I fix that?

Thanks for any help!

---------- Post added at 12:44 PM ---------- Previous post was at 12:42 PM ----------

Quote:
Originally Posted by stalin.sk2

flash the stock firmware (here you have to wipe cache and data)

no need to unlock bootloader once again already unlocked

follow the root instructions step by step

don't wipe cache and data(it will erase all your user data)

before flashing or changes with cwm please take a complete backup its help you to revert your phone.

Thanks, but as a newbie (at least to this phone) I'd appreciate more detailed guidance as to how to find the correct firmware (I'm on Android 4.3 stock, UK) and how to flash it safely.
31st May 2014, 01:57 PM   |  #4  
stalin.sk2's Avatar
Senior Member
Flag Madurai
Thanks Meter: 45
 
127 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by pcgardner

I had exactly the same experience (except that I didn't install supersu) with my Xperia M C1905 a few days ago, and have been struggling unsuccessfully to fix it. In my case the phone got stuck at the animated boot logo after I unlocked the bootloader, even though I used the official Sony method and followed the instructions to the letter, and it said it worked OK with no errors. After that I successfully flashed a CWM boot image, and can now boot into recovery, but normal boot is still stuck at the logo. I can access the phone with flashboot but not adb. I have the correct Windows 7 drivers installed.

In CWM I find (like the previous poster) that I cannot mount or format /data, so I assume that's the cause of the problem. Does this mean that the data partition has got corrupted? If so, how can I fix that?

Thanks for any help!

---------- Post added at 12:44 PM ---------- Previous post was at 12:42 PM ----------



Thanks, but as a newbie (at least to this phone) I'd appreciate more detailed guidance as to how to find the correct firmware (I'm on Android 4.3 stock, UK) and how to flash it safely.

to know correct firmware go to settings--> about phone--->Model Name/Built Number
then go to google enter "phone model no + built number +ftf" you can easily get your firmware
for flashing this ftf reffer this
31st May 2014, 02:24 PM   |  #5  
Junior Member
Thanks Meter: 3
 
22 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by stalin.sk2

to know correct firmware go to settings--> about phone--->Model Name/Built Number
then go to google enter "phone model no + built number +ftf" you can easily get your firmware
for flashing this ftf reffer this

Thanks for the link to the guide for flashing FTF files with Flashtool.

As I can't boot my phone, I can't go to settings > about phone! Am I safe to use a Global FTF? Or do I need a specific UK version?
31st May 2014, 02:25 PM   |  #6  
stalin.sk2's Avatar
Senior Member
Flag Madurai
Thanks Meter: 45
 
127 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by pcgardner

Thanks for the link to the guide for flashing FTF files with Flashtool.

As I can't boot my phone, I can't go to settings > about phone! Am I safe to use a Global FTF? Or do I need a specific UK version?

global is enough
31st May 2014, 02:37 PM   |  #7  
Senior Member
Thanks Meter: 12
 
147 posts
Join Date:Joined: Mar 2014
More
Maybe, after unlocking the bootloader, you are not turn on your XM, but instead immediately installing cwm?

Sory for my engelish
31st May 2014, 06:25 PM   |  #8  
Junior Member
Thanks Meter: 3
 
22 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by itsnie

Maybe, after unlocking the bootloader, you are not turn on your XM, but instead immediately installing cwm?

Sory for my engelish

Perhaps that would have been better! But I wanted to check that the bootloader unlocking had worked correctly and that the phone was still OK. (It wasn't.) At least this way I know when the problem occurred.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes