FORUMS

Disable home button wake on NC5 to MK2 to rooted NC5 ROM

26 posts
Thanks Meter: 11
 
By usegnu, Junior Member on 20th May 2014, 01:08 PM
Post Reply Subscribe to Thread Email Thread
I used the Surge1223 method to downgrade then upgrade to rooted NC5. Everything works good except I can not disable the home button from waking when locked.
I tried removing "WAKE" from gpio-keys.kl & Generic.kl, the options stick after a reboot but it will not disable the home button from waking when locked?
If I remove the key 172 entry it disables the home button, so I know it is reading/using the files. Just not removing the wake option.

Has anybody else found a way to fix this?

Sent from my Sero 7 Pro using XDA Premium HD app
 
 
21st May 2014, 04:15 AM |#2  
bryantjopplin's Avatar
Senior Member
Thanks Meter: 344
 
More
If your rooted get xposed and install Wanam module there is a setting in there.

Sent from my SCH-I545 using Tapatalk
21st May 2014, 01:18 PM |#3  
usegnu's Avatar
OP Junior Member
Thanks Meter: 11
 
More
Installing xposed with the wanam module worked.
But I would still like to know why it will not work by changing the gpio-keys.kl file?

Sent from my Sero 7 Pro using Tapatalk
21st May 2014, 02:49 PM |#4  
bryantjopplin's Avatar
Senior Member
Thanks Meter: 344
 
More
Quote:
Originally Posted by usegnu

Installing xposed with the wanam module worked.
But I would still like to know why it will not work by changing the gpio-keys.kl file?

Sent from my Sero 7 Pro using Tapatalk

Is probably linked to some other file as well. Tear apart the wanam apk and see what you find.

Sent from my SCH-I545 using Tapatalk
31st May 2014, 11:49 PM |#5  
usegnu's Avatar
OP Junior Member
Thanks Meter: 11
 
More
I took a quick look through wanam, but I did not see anything. Just the enable/disable string. Still do not know what it is changing to make it work.

<public type="string" name="disable_wake_home_button" id="0x7f070183" />
<public type="string" name="disable_wake_home_button_on" id="0x7f070184" />
<public type="string" name="disable_wake_home_button_off" id="0x7f070185" />

Sent from my Sero 7 Pro using Tapatalk
Last edited by usegnu; 1st June 2014 at 12:35 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes