Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

PAC Building Error.

OP Uzayr

30th May 2014, 05:49 PM   |  #11  
Uzayr's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 487
 
387 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by MasterAwesome

Try syncing your repository..

And try

Sudo updates-alternatives --config java

And two me output

Regards
MasterAwesome

i got OpenJDK 6 & 7 and i switch between them when i have to.

Code:
android@builduntu:~$ sudo update-alternatives --config java
[sudo] password for android: 
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      auto mode
  1            /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java   1061      manual mode
  2            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode

Press enter to keep the current choice[*], or type selection number:
and syncing is fine..i just did a re-sync again.
30th May 2014, 06:01 PM   |  #12  
MasterAwesome's Avatar
Senior Member
Thanks Meter: 810
 
1,142 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by Uzayr

i got OpenJDK 6 & 7 and i switch between them when i have to.

Code:
android@builduntu:~$ sudo update-alternatives --config java
[sudo] password for android: 
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      auto mode
  1            /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java   1061      manual mode
  2            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode

Press enter to keep the current choice[*], or type selection number:
and syncing is fine..i just did a re-sync again.

There's your error you need sun java.. Oracle JDK 1.6 others are not supported.

Regards
MasterAwesome
30th May 2014, 06:34 PM   |  #13  
Uzayr's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 487
 
387 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by MasterAwesome

There's your error you need sun java.. Oracle JDK 1.6 others are not supported.

Regards
MasterAwesome

i had previously Oracle jdk 1.6 when i started this build. but after these errors i switched to open jdk.

oracle jdk 7 breaks my java installation.
30th May 2014, 06:49 PM   |  #14  
MasterAwesome's Avatar
Senior Member
Thanks Meter: 810
 
1,142 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by Uzayr

i had previously Oracle jdk 1.6 when i started this build. but after these errors i switched to open jdk.

oracle jdk 7 breaks my java installation.

yeah you're not supposed to use jdk 7 for now android supports only jdk 1.6_45 :/

first, extract jdk 1.6.bin to your /usr/lib/jvm
and you're supposed to update-configurations for each java binary
rename the .txt attched to .sh and make it runnable by using chmod a+x filename and run it.. you'll get options choose sun java 1.6 and click update. this will make it work.
Attached Files
File Type: txt update-java-0.5b.sh.txt - [Click for QR Code] (6.6 KB, 10 views)
Last edited by MasterAwesome; 30th May 2014 at 06:55 PM.
The Following User Says Thank You to MasterAwesome For This Useful Post: [ View ]
30th May 2014, 07:04 PM   |  #15  
Uzayr's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 487
 
387 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by MasterAwesome

yeah you're not supposed to use jdk 7 for now android supports only jdk 1.6_45 :/

first, extract jdk 1.6.bin to your /usr/lib/jvm
and you're supposed to update-configurations for each java binary
rename the .txt attched to .sh and make it runnable by using chmod a+x filename and run it.. you'll get options choose sun java 1.6 and click update. this will make it work.

i'll try it out and let you know, ASAP
thank you
30th May 2014, 08:18 PM   |  #16  
MasterAwesome's Avatar
Senior Member
Thanks Meter: 810
 
1,142 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by Uzayr

i'll try it out and let you know, ASAP
thank you

ASAP=as slow as possible?

Jk :P

Regards
MasterAwesome
31st May 2014, 05:36 PM   |  #17  
Uzayr's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 487
 
387 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by MasterAwesome

ASAP=as slow as possible?

Jk :P

Regards
MasterAwesome

lol,

alright...i get the same error when using Oracle's Java 6

Code:
android@builduntu:~$ java -version
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)
android@builduntu:~$ javac -version
javac 1.6.0_45
android@builduntu:~$
31st May 2014, 05:42 PM   |  #18  
MasterAwesome's Avatar
Senior Member
Thanks Meter: 810
 
1,142 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by Uzayr

lol,

alright...i get the same error when using Oracle's Java 6

Code:
android@builduntu:~$ java -version
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)
android@builduntu:~$ javac -version
javac 1.6.0_45
android@builduntu:~$

Okay send me the build/core/java.mk I'll check it

Regards
MasterAwesome
1st June 2014, 07:46 AM   |  #19  
Uzayr's Avatar
OP Senior Member
Flag Chennai
Thanks Meter: 487
 
387 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by MasterAwesome

Okay send me the build/core/java.mk I'll check it

Regards
MasterAwesome

I have attaches
Attached Files
File Type: zip java.mk.zip - [Click for QR Code] (5.6 KB, 3 views)

Post Reply Subscribe to Thread

Tags
build, errors, java, local_sdk_version, pac
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes