Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,276 Members 44,732 Now Online
XDA Developers Android and Mobile Development Forum

[Q] unable to flash anyrom after kitkat port

Tip us?
 
Athosbr99
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Dec 2011
Location: Londrina

 
DONATE TO ME
Default [Q] unable to flash anyrom after kitkat port

Hi there,

I flashed a KitKat port to test it. However, I decided to go back to Cyanogenmod since it didn't work very well.

However, any ROM that I try to flash appears this error:

format() expects 5 args, got 3
E: Error in /storage/sdcard0/cm-7.2.0-p500.zip
(Status 7)
Installation aborted

what can I do to fix this? thanks
 
Dovidhalevi
Old
#2  
Senior Member
Thanks Meter 965
Posts: 2,002
Join Date: Jun 2012
Quote:
Originally Posted by Athosbr99 View Post
Hi there,

I flashed a KitKat port to test it. However, I decided to go back to Cyanogenmod since it didn't work very well.

However, any ROM that I try to flash appears this error:

format() expects 5 args, got 3
E: Error in /storage/sdcard0/cm-7.2.0-p500.zip
(Status 7)
Installation aborted

what can I do to fix this? thanks
To flash that KitKat, you had to place a newer CWM or TWRP recovery version.
To flash cm-7.2, you need to go back to the older recovery!
The Following User Says Thank You to Dovidhalevi For This Useful Post: [ Click to Expand ]
 
shinobisoft
Old
#3  
shinobisoft's Avatar
Recognized Contributor
Thanks Meter 1862
Posts: 2,045
Join Date: Feb 2012
Location: Knoxville, TN

 
DONATE TO ME
For KitKat ROMs a recovery equivalent to 6.0.4.5 or newer is required to flash. The newer recoveries are capable of flashing CM 10.2 to CM11. All older Android versions will require the use of an older recovery, pre 6.0.4.5, such as CWM 5.0.2.7 Touch by vivekkalady.

"The way is known to all but not all know it"
My Devices, Mods, and Tools
 
Device: LG Optimus L90 LG-D415 ROOTED, Bootloader.UNLOCKED, TWRP 2.7.1.0, Stock KitKat 4.4.2
Device: LG Optimus L9 LG-P769 ROOTED, Bootloader.LOCKED, CWM 6.0.1.2 ( L9RecoveryInstaller ), Stock JellyBean 4.1.2
Device: LG Optimus T LG-P509 ROOTED, Bootloader.UNLOCKED, CWM 5.0.2.7 Touch, CM10
My Stuff
The Following User Says Thank You to shinobisoft For This Useful Post: [ Click to Expand ]
 
Athosbr99
Old
#4  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Dec 2011
Location: Londrina

 
DONATE TO ME
Quote:
Originally Posted by Dovidhalevi View Post
To flash that KitKat, you had to place a newer CWM or TWRP recovery version.
To flash cm-7.2, you need to go back to the older recovery!
Quote:
Originally Posted by shinobisoft View Post
For KitKat ROMs a recovery equivalent to 6.0.4.5 or newer is required to flash. The newer recoveries are capable of flashing CM 10.2 to CM11. All older Android versions will require the use of an older recovery, pre 6.0.4.5, such as CWM 5.0.2.7 Touch by vivekkalady.
nice to know that. I will try later

In other subject, I tried other kitkat roms and they gave me that same error. the only one that worked was Omega. is there any reason to that?
 
shinobisoft
Old
#5  
shinobisoft's Avatar
Recognized Contributor
Thanks Meter 1862
Posts: 2,045
Join Date: Feb 2012
Location: Knoxville, TN

 
DONATE TO ME
Quote:
Originally Posted by Athosbr99 View Post
nice to know that. I will try later

In other subject, I tried other kitkat roms and they gave me that same error. the only one that worked was Omega. is there any reason to that?
Sorry, I honestly can't say. I no longer use this device so I've been out of the loop for some time now.

"The way is known to all but not all know it"
My Devices, Mods, and Tools
 
Device: LG Optimus L90 LG-D415 ROOTED, Bootloader.UNLOCKED, TWRP 2.7.1.0, Stock KitKat 4.4.2
Device: LG Optimus L9 LG-P769 ROOTED, Bootloader.LOCKED, CWM 6.0.1.2 ( L9RecoveryInstaller ), Stock JellyBean 4.1.2
Device: LG Optimus T LG-P509 ROOTED, Bootloader.UNLOCKED, CWM 5.0.2.7 Touch, CM10
My Stuff
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes