Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Major Update for the Sony Smartwatch 2 Brings DND and More

With the wearables landscape now dominated by Android Wear and Pebble, its … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

HTC ONE wont turn on

OP rickrollboy

1st June 2014, 07:20 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
Hi everybody.
I've bought the phone today.
It's in mint condition, lcd isn't cracked.

It won't turn on. I've tried to reboot it, it didn't help.
Back and home button is blinking when i release power button.
I've entered to fastboot blindfold with keys, flashed RUU 4.4 rom, that didn't help. But it gave something - phone produces the power on sound.
PC detects it as default - MTP device.
Now it's charging - led is lighting.

What should i try?
i don't think that the lcd is the main problem - it looks like new. i've disconnected it from the housing - no any signs of damage.
1st June 2014, 07:39 PM   |  #2  
majmoz's Avatar
Senior Member
Flag Sonoita
Thanks Meter: 352
 
1,202 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by rickrollboy

Hi everybody.
I've bought the phone today.
It's in mint condition, lcd isn't cracked.

It won't turn on. I've tried to reboot it, it didn't help.
Back and home button is blinking when i release power button.
I've entered to fastboot blindfold with keys, flashed RUU 4.4 rom, that didn't help. But it gave something - phone produces the power on sound.
PC detects it as default - MTP device.
Now it's charging - led is lighting.

What should i try?
i don't think that the lcd is the main problem - it looks like new. i've disconnected it from the housing - no any signs of damage.

Let it charge up fully while it is off. Don't power it up until the LED turns green.
1st June 2014, 08:00 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by majmoz

Let it charge up fully while it is off. Don't power it up until the LED turns green.

No results.
1st June 2014, 08:18 PM   |  #4  
Senior Member
Thanks Meter: 443
 
1,801 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by rickrollboy

No results.

So.. What makes you think it is NOT a screen issue?
1st June 2014, 08:27 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by SaHiLzZ

So.. What makes you think it is NOT a screen issue?

1. It is cosmetically new, no any signs of damage (i know, this don't give a 100%confidence), but that's strange.
2.I think that back and home buttons are connected with display - that means that electricify is supplied.
1st June 2014, 08:30 PM   |  #6  
Senior Member
Thanks Meter: 443
 
1,801 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by rickrollboy

1. It is cosmetically new, no any signs of damage (i know, this don't give a 100%confidence), but that's strange.
2.I think that back and home buttons are connected with display - that means that electricify is supplied.

So not sure on both accounts.
1st June 2014, 10:00 PM   |  #7  
rider5512's Avatar
Senior Member
Flag Buxton
Thanks Meter: 1,846
 
2,802 posts
Join Date:Joined: Feb 2010
More
Quote:
Originally Posted by rickrollboy

Hi everybody.
I've bought the phone today.
It's in mint condition, lcd isn't cracked.

It won't turn on. I've tried to reboot it, it didn't help.
Back and home button is blinking when i release power button.
I've entered to fastboot blindfold with keys, flashed RUU 4.4 rom, that didn't help. But it gave something - phone produces the power on sound.
PC detects it as default - MTP device.
Now it's charging - led is lighting.

What should i try?
i don't think that the lcd is the main problem - it looks like new. i've disconnected it from the housing - no any signs of damage.

erm... it's obviously not in mint condition. Take it back for a refund.
2nd June 2014, 01:05 AM   |  #8  
Senior Member
Flag Melbourne
Thanks Meter: 98
 
594 posts
Join Date:Joined: Jul 2010
More
Did you try shining a bright light on the proximity sensor while holding power and down?

Sent from my HTC One using XDA Premium 4 mobile app
2nd June 2014, 05:31 AM   |  #9  
alray's Avatar
Senior Member
Flag Montreal, Quebec
Thanks Meter: 1,386
 
3,589 posts
Join Date:Joined: May 2012
Donate to Me
More
So the phone can boot (you can hear the boot sound and its correctly recognized by your computer) but there is nothing displayed on the screen = hardware damage. Either a bad LCD, bad cable or even a bad main board (maybe a badly connected cable)

so as said before, return the phone.

---------- Post added at 11:31 PM ---------- Previous post was at 11:23 PM ----------

Quote:
Originally Posted by rickrollboy

1. It is cosmetically new, no any signs of damage

If you are interested, I have a ''cosmetically new'' Htc One X to sell no offense

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes