Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,526 Members 50,350 Now Online
XDA Developers Android and Mobile Development Forum

[Q] CM11 WiFi Connection Issue

Tip us?
 
jeremymichaeldlima
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Location: Singapore
Default [Q] CM11 WiFi Connection Issue

Hey guys! I have only just joined XDA Developers so please excuse me if I have posted this thread in the wrong area. I have a Samsung Galaxy S Advance (GT-I9070) running stock Jellybean firmware (4.1.2 ITV) but as you all know the stock firmware for this device is full of bugs and freezes often. I successfully rooted my device and installed Team Canjica's CM10.2 ROM (4.3) from the thread on XDA Developers but the WiFi wasn't working. I then installed Maclaw's CM11 ROM (KitKat) because I thought that might solve the issue but it didn't. Here are the details:
  • Device scans for nearby wireless routers.
  • I type in the password for my home router.
  • Device saves router. "Saved, Secured" message displayed.
  • I tap on my home router in the list to connect.
  • Device says "Connecting" for a couple of seconds and then goes back to saying "Saved, Secured".

I browsed through the forums and some users suggested switching WiFi Frequency to Auto and turning off WiFi Optimisation but neither of those methods worked for me. The ROM was installed successfully and all other features are working properly so I don't think that is the issue. And my router settings are also alright since I am able to connect to it from my Nexus 7 (2013) properly. Can someone please provide me with a working solution for this issue? I will start receiving very high data usage bills soon because my data plan isn't unlimited. Thank you!
 
th3cr0w
Old
#2  
th3cr0w's Avatar
Senior Member
Thanks Meter 56
Posts: 180
Join Date: Nov 2012
Is your ssid hidden (not broadcasted) by any chance? i had those troubles on hidden home network. Sometimes it worked after a while, sometimes it didn't. What helped me is to broadcast ssid for a moment, get connected with phone, remove broadcast (it will reboot router so phone will lose wifi for a moment). Then somehow it got connected normally

Sent from my SGS Adv. using xda-developers app.
Previous:
- stock JB 4.1.2 XXLQE (XEO) + CoCore 7.6 (CWM)
- CM10.1
- CM10.2
- CM11 by Maclaw
Current: CM11 by TeamCanjica
on i9070
 
jeremymichaeldlima
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Location: Singapore
Default idedItp from

I just checked my router settings and SSID Broadcast is enabled. I tried flashing OmniRom 4.3 thinking that this may be because of a problem with CyanogenMod but the problem still persists. Is there any additional kernel that I was supposed to install perhaps?
 
Nishad1982
Old
#4  
Nishad1982's Avatar
Senior Member
Thanks Meter 30
Posts: 183
Join Date: Sep 2013
Location: Dubai
Default CyanogenMod 11 version ?

Quote:
Originally Posted by jeremymichaeldlima View Post
I just checked my router settings and SSID Broadcast is enabled. I tried flashing OmniRom 4.3 thinking that this may be because of a problem with CyanogenMod but the problem still persists. Is there any additional kernel that I was supposed to install perhaps?
Which version CyanogenMod 11 are you using?
~the needs of the many outweigh the needs of the few~

Device - Samsung Galaxy S Advance GT-I9070 KERNEL - CoCore E9.8 ROM - HarshJelly 5.2odexed Baseband - I9070JVBMD1 with Nova Launcher, exDialer and Textra SMS
 
ADR USR
Old
(Last edited by ADR USR; 18th March 2014 at 01:00 AM.)
#5  
Senior Member
Thanks Meter 47
Posts: 162
Join Date: Dec 2011
Quote:
Originally Posted by jeremymichaeldlima View Post
Hey guys! I have only just joined XDA Developers so please excuse me if I have posted this thread in the wrong area. I have a Samsung Galaxy S Advance (GT-I9070) running stock Jellybean firmware (4.1.2 ITV) but as you all know the stock firmware for this device is full of bugs and freezes often. !

Just a detail to those who have not upgraded to JB stock and think it is impossible to use it without problems:
All bugs and freezes in Stock JB currently are perfectly finished.

I use STOCK, only with modified kernel (cocore 8.2) without freezes or bugs in months of use.

Enjoy the developer's work (cocafe), because without it JB probably would be impossible in SGA. However we have JB 100% functional and bug-free.

About KK and WIFI bugs:

The only KK (or based) ROM that used without WIFI bugs was RR 20140313.
In fact, the only issue is incall vol. in my experience.

WiFi Direct, Camera -> Panorama is laggy , Screen Recorder not working Not Tested

I also noticed that the battery is worse durability.
But I went back to JB Stock -- personal preference.
The Following User Says Thank You to ADR USR For This Useful Post: [ Click to Expand ]
 
jeremymichaeldlima
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Location: Singapore
Quote:
Originally Posted by ADR USR View Post
Just a detail to those who have not upgraded to JB stock and think it is impossible to use it without problems:
All bugs and freezes in Stock JB currently are perfectly finished.

I use STOCK, only with modified kernel (cocore 8.2) without freezes or bugs in months of use.

Enjoy the developer's work (cocafe), because without it JB probably would be impossible in SGA. However we have JB 100% functional and bug-free.

About KK and WIFI bugs:

The only KK (or based) ROM that used without WIFI bugs was RR 20140313.
In fact, the only issue is incall vol. in my experience.

WiFi Direct, Camera -> Panorama is laggy , Screen Recorder not working Not Tested

I also noticed that the battery is worse durability.
But I went back to JB Stock -- personal preference.
Actually I did try that method. Flashed Samsung's latest stock firmware I9070XXLQL (ITV) and then rooted and installed CoCore. To be honest overall performance was much better and UI smoothness was improved. But after a couple of days of regular usage with just a few basic applications such as a note taker, train arrival time, WhatsApp etc. the device started freezing up a couple of times a day again. I admit it worked much better than before but freezes and hangs were still quite frequent. Running OmniROM 4.3 now with no issues so far except for dialer FC, laggy panorama and non functional WiFi hotspot.
 
PradeepMurugan
Old
#7  
PradeepMurugan's Avatar
Senior Member
Thanks Meter 237
Posts: 218
Join Date: Oct 2013
Location: Karur

 
DONATE TO ME
Quote:
Originally Posted by jeremymichaeldlima View Post
Hey guys! I have only just joined XDA Developers so please excuse me if I have posted this thread in the wrong area. I have a Samsung Galaxy S Advance (GT-I9070) running stock Jellybean firmware (4.1.2 ITV) but as you all know the stock firmware for this device is full of bugs and freezes often. I successfully rooted my device and installed Team Canjica's CM10.2 ROM (4.3) from the thread on XDA Developers but the WiFi wasn't working. I then installed Maclaw's CM11 ROM (KitKat) because I thought that might solve the issue but it didn't. Here are the details:
  • Device scans for nearby wireless routers.
  • I type in the password for my home router.
  • Device saves router. "Saved, Secured" message displayed.
  • I tap on my home router in the list to connect.
  • Device says "Connecting" for a couple of seconds and then goes back to saying "Saved, Secured".

I browsed through the forums and some users suggested switching WiFi Frequency to Auto and turning off WiFi Optimisation but neither of those methods worked for me. The ROM was installed successfully and all other features are working properly so I don't think that is the issue. And my router settings are also alright since I am able to connect to it from my Nexus 7 (2013) properly. Can someone please provide me with a working solution for this issue? I will start receiving very high data usage bills soon because my data plan isn't unlimited. Thank you!
This means probably you have typed wrong password. Also check that in keyboard it capitalise first letter automatically. forget the network and connect again
 
rudra75
Old
#8  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Jan 2013
Default WIFI not working with cm-11-20140521-UNOFFICIAL-janice and cm11.0_janice.nova.201406

Same wifi problem with cm-11-20140521-UNOFFICIAL-janice and cm11.0_janice.nova.20140601. Wifi not connecting even after giving the right password (used to work correctly with jb4.1.2 and still works with desktop) only showing saving and connecting wifi. Then the wifi connection is shown to be saved. If wifi does not work with cyanogenmod11, then what's the use of upgrading?
Is wifi is not working in any custom kitkat Rom?
Please suggest a solution.
 
shut_down
Old
#9  
shut_down's Avatar
Senior Member
Thanks Meter 3297
Posts: 7,376
Join Date: Sep 2010
Location: Belgrade
Try couple times to connect. I remember sometimes I had to reconnect 2-3 times before it gets connection. And the problem with kernel was about WIFI not turning on at all, it was not even search SSIDs.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


MacroDroid Update Brings Android Wear Automation

A few months ago, we talked about MacroDroid. For those who don’t remember, MacroDroid … more

Droid X Receives KitKat Port, Upcoming Google Glass Firmware Improvements – XDA Developer TV

Android 4.4.3 lands on the European HTC … more

Calc+ is a Smart and Beautiful Android Calculator

As we’ve said inthe past, there are quite a few calculators available on Android. … more

Get Better Debug Data with Crash Report SDK

Developing an application is a hard and often times ungratifying task. It also requires quite a … more