FORUMS

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

[APP] [+3.0] Wifi Scheduler

2,846 posts
Thanks Meter: 1,404
 
By bartito, Recognized Developer on 31st May 2014, 08:15 PM
Post Reply Subscribe to Thread Email Thread
3rd June 2014, 09:45 AM |#51  
Senior Member
Flag Lisboa
Thanks Meter: 32
 
More
Quote:
Originally Posted by jolas

I'm sorry to say but as long as this bug exists this application is useless as it is not an automatic WiFi management application.

There is no difference between manually turn on/off WiFi or manually turn on/off airplane mode, to make this application to work...

Sent from my Nexus 4

I see your point, but i'm not getting that bug many times, just occasionally.
 
 
3rd June 2014, 10:11 AM |#52  
Senior Member
Flag Berlin
Thanks Meter: 41
 
More
It seems that i got this bug immediately when i'm leaving the wifi range and the scheduler turns wifi off. If i came back or join another cell with a known wifi after some time the scheduler doesn't activate wifi anymore and manually it's not possible. So for me it's very often.

And if i have to do something manually, check the phone everytime when i'm in the wifi range and just cannot trust that it works correctly then the app is sadly useless. Because then it wastes battery and mobile data traffic and so it's even better to let wifi always on.

I like the idea and used "y5 battery saver" a long time ago. I dont want to bash the app or sth like that. I just want to report the bug and i hope he can fix it.
4th June 2014, 10:28 PM |#53  
bartito's Avatar
OP Recognized Developer
Thanks Meter: 1,404
 
Donate to Me
More
Quote:
Originally Posted by tzyn

I have the same problem. Because of that the app didnt enable wifi when i'm in the green cell again. So with that bug the wifi scheduler isn't useful.

I'm using cm11 on a Galaxy S4. But never had a problem to enable/disable Wifi.


What time have you configured to pass before enable wifi when you connect to a green cell tower?
Remember that when app enable wifi it will be automatically disabled after a while (2 minutes by default) if wifi connection isn't established.
4th June 2014, 10:33 PM |#54  
bartito's Avatar
OP Recognized Developer
Thanks Meter: 1,404
 
Donate to Me
More
Please,

I'm using the app in my daily with no problems.

If any is suffering any problem, please, post a logcat.

Thanks
The Following User Says Thank You to bartito For This Useful Post: [ View ]
5th June 2014, 01:35 AM |#55  
Mike B.'s Avatar
Senior Member
/dev/null
Thanks Meter: 1,240
 
Donate to Me
More
Using Wifi Scheduler PRO 2.1.60 with the GEO 1.0.11 and RANKING 1.04 modules. No problem here but a request: for those of us in the few remaining countries that haven't switched to metric yet: it would be nice if the toast from the geolocation module ("You are at about xxxx kilometers of the cell tower") could show distances in miles instead of km. Since it's using Google Maps, it's probably feasible without major headaches but I haven't found a way with the current version.
5th June 2014, 06:26 AM |#56  
bartito's Avatar
OP Recognized Developer
Thanks Meter: 1,404
 
Donate to Me
More
Quote:
Originally Posted by Mike B.

Using Wifi Scheduler PRO 2.1.60 with the GEO 1.0.11 and RANKING 1.04 modules. No problem here but a request: for those of us in the few remaining countries that haven't switched to metric yet: it would be nice if the toast from the geolocation module ("You are at about xxxx kilometers of the cell tower") could show distances in miles instead of km. Since it's using Google Maps, it's probably feasible without major headaches but I haven't found a way with the current version.

Added to the new release.
Last edited by bartito; 5th June 2014 at 07:51 AM.
The Following User Says Thank You to bartito For This Useful Post: [ View ]
5th June 2014, 07:03 AM |#57  
Mike B.'s Avatar
Senior Member
/dev/null
Thanks Meter: 1,240
 
Donate to Me
More
If I remember correctly, the default for the Google Maps API is metric (UnitSystem.METRIC?) for kilometers/meters but it also allows imperial (UnitSystem.IMPERIAL?) for miles/feet.
The Following User Says Thank You to Mike B. For This Useful Post: [ View ]
5th June 2014, 09:30 AM |#58  
Senior Member
Flag Berlin
Thanks Meter: 41
 
More
Quote:
Originally Posted by bartito

What time have you configured to pass before enable wifi when you connect to a green cell tower?
Remember that when app enable wifi it will be automatically disabled after a while (2 minutes by default) if wifi connection isn't established.

I used stock settings. So nothing is changed.

And yes, i know. But the problem is that i cannot activate wlan anymore. Not for a second. In the status bar if i tick the wlan toggle or "enable wifi" on the wifi scheduler notification and in android settings if i tick the slider it stays off and nothing happen. So if i'm in the range of a new wlan (unknown to wifi scheduler yet and need to learn) i cannot activate wifi. And if i join the cell of a known wifi and stand near by the router the wifi scheduler also doesn't (or cannot) activate wifi anymore. No matter how long i wait (1, 2 or more hours).
Last edited by tzyn; 5th June 2014 at 09:35 AM.
5th June 2014, 09:40 AM |#59  
bartito's Avatar
OP Recognized Developer
Thanks Meter: 1,404
 
Donate to Me
More
Quote:
Originally Posted by tzyn

I used stock settings. So nothing is changed.

And yes, i know. But the problem is that i cannot activate wlan anymore. Not for a second. In the status bar if i tick the wlan toggle or "enable wifi" on the wifi scheduler notification and in settings if i tick the slider it stays off and nothing happen. So if i'm in a range of a new wlan that wifi scheduler didn't know yet and need to learn i cannot activate wifi.

I think this is a hardware/kernel issue (possibly induced by the app, I don't know ATM).
Please, can you post (or send by email) a logcat when you have this issue.

When I developing the app I have suffer a similar issue sometimes.
The app was enabling/disabling the Wifi correctly, but sometimes, when the app (or manually) enable the wifi, it can enable but can't connect (the icon remains in white (JB) or orange (KK)).
This is a kernel issue and was solved in a recent update of CM-11 (this is the ROM that I use).
5th June 2014, 09:44 AM |#60  
Senior Member
Flag Lisboa
Thanks Meter: 32
 
More
Quote:
Originally Posted by bartito

I think this is a hardware/kernel issue (possibly induced by the app, I don't know ATM).
Please, can you post (or send by email) a logcat when you have this issue.

When I developing the app I have suffer a similar issue sometimes.
The app was enabling/disabling the Wifi correctly, but sometimes, when the app (or manually) enable the wifi, it can enable but can't connect (the icon remains in white (JB) or orange (KK)).
This is a kernel issue and was solved in a recent update of CM-11 (this is the ROM that I use).

Also suffer from this.
I'm on PacRom 4.3.1 and apolo kernel, samsung i9100.
as i said when this happens i activate and deactivate airplane mode and it starts working again.
5th June 2014, 09:53 AM |#61  
bartito's Avatar
OP Recognized Developer
Thanks Meter: 1,404
 
Donate to Me
More
Quote:
Originally Posted by joaonuno

Also suffer from this.
I'm on PacRom 4.3.1 and apolo kernel, samsung i9100.
as i said when this happens i activate and deactivate airplane mode and it starts working again.

Please,

I attach a new version of the app.

The only difference BTW this and the last released version is:

It delays enable/disable wifi for 10 seconds if wifi state is changing (a disable or enable is started but not ended).

Please, try if this solves the issue.

Thanks!
Attached Files
File Type: apk WirelessManager-2.1.62-DELAY.apk - [Click for QR Code] (1.22 MB, 65 views)
The Following 2 Users Say Thank You to bartito For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes