Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,438 Members 42,712 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bluetooth won't turn on

Tip us?
 
boctok
Old
(Last edited by boctok; 2nd June 2014 at 05:52 PM.) Reason: Update
#1  
Member - OP
Thanks Meter 0
Posts: 43
Join Date: Oct 2010
Default [Q] Bluetooth won't turn on

This morning, when starting my commute to work, I noticed that the S5 wasn't connecting to my BT car stereo. I checked the phone and BT was off. I tapped the icon and it did the slight dimming for a few seconds and then went back to the off state. I opened up BT settings and tapped the slider to turn it on, got the message "Turning on bluetooth", but again, after a few seconds, it returned to the off position.

I'm running the stock ROM, rooted with the hotspot mod, and the restart menu mod.

I tried restarting, powering off and removing battery and restarting, restarting and hitting the BT settings as quickly as possible, but it still will not work. Permissions on /system/vendor/lib/libbt-vendor.so are rw-r--r--, so I don't think it has anything to do with permissions.

I read a thread regarding a different phone and ROM having this problem and they fixed it by flashing a different kernel. Any ideas before I take this route?

EDIT: Just to be sure, I rebooted into recovery and ran fix permissions. No change.

Does anyone have the stock kernel that I can try to flash or Odin? Thought I might give this a try before going with a modded kernel.

Thanks
 
boctok
Old
#2  
Member - OP
Thanks Meter 0
Posts: 43
Join Date: Oct 2010
As much as I hated to do it, a factory reset fixed the problem. Still don't know what actually caused the problem.
 
DistrictDigital
Old
#3  
DistrictDigital's Avatar
Senior Member
Thanks Meter 39
Posts: 330
Join Date: Sep 2011
Location: Colorado
Quote:
Originally Posted by boctok View Post
As much as I hated to do it, a factory reset fixed the problem. Still don't know what actually caused the problem.
Are you going to reflash the mods you were using to see if the problem was the same? Also, you might be able to just make a backup of your system/data/recovery and flash it over so you don't have to factory reset.

Sent from my SM-G900P using XDA Premium 4 mobile app
Current Phone : Sprint Samsung Galaxy Note 3 @ Sprint
ROM : PAC-man
Recovery : Philz Touch
Past Phones:
Sprint Samsung Galaxy S5 @ Sprint
Sprint Samsung Galaxy S4 Mini @ Sprint
T-Mobile myTouch 4G Slide/HTC Doubleshot @ T-Mobile
T-Mobile myTouch 4G / HTC Glacier @ T-Mobile
HTC Eris @ Verizon
__________________________________________________

Don't be afraid to give thanks to those who deserve it!
 
boctok
Old
#4  
Member - OP
Thanks Meter 0
Posts: 43
Join Date: Oct 2010
Quote:
Originally Posted by DistrictDigital View Post
Are you going to reflash the mods you were using to see if the problem was the same? Also, you might be able to just make a backup of your system/data/recovery and flash it over so you don't have to factory reset.

Sent from my SM-G900P using XDA Premium 4 mobile app
I tried the backup, but it brought the problem back as well. Not sure if it was something in the system or days our apps. Still need to do some forensics.
 
DistrictDigital
Old
#5  
DistrictDigital's Avatar
Senior Member
Thanks Meter 39
Posts: 330
Join Date: Sep 2011
Location: Colorado
If you flashed off of an SD card, sometimes you can get subtle corruptions? I thought I saw something about it before..

Sent from my SM-G900P using XDA Premium 4 mobile app
Current Phone : Sprint Samsung Galaxy Note 3 @ Sprint
ROM : PAC-man
Recovery : Philz Touch
Past Phones:
Sprint Samsung Galaxy S5 @ Sprint
Sprint Samsung Galaxy S4 Mini @ Sprint
T-Mobile myTouch 4G Slide/HTC Doubleshot @ T-Mobile
T-Mobile myTouch 4G / HTC Glacier @ T-Mobile
HTC Eris @ Verizon
__________________________________________________

Don't be afraid to give thanks to those who deserve it!
Tags
bluetooth not working
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes