Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,152 Members 54,087 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Hardware issue, please give me your two cents

Tip us?
 
dafater
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2012
Default [Q] Hardware issue, please give me your two cents

So I was being a stupid ass and disconnected the LCD cable from the motherboard before turn off the system. Now the screen doesn't turn on.
Here's what I know for sure:
1. The system turns on, I can hear the processor working.
2. Before I completely lost the ability to have it show anything on screen, I tested two different screens and they both displayed something, albeit in weird colors (showed the correct color if I kinda yanked on the cable), so the screen is not the issue.
Here's my question, where do you guys think the problem lies? The cable? Or the connection socket on the motherboard?

Any answer is greatly appreciated.
 
Captain Sweatpants
Old
#2  
Captain Sweatpants's Avatar
Senior Member
Thanks Meter 83
Posts: 328
Join Date: Feb 2014
Location: Edinburgh
If you are able to test multiple screens and ribbons with no effect then I would say your problem is the motherboard connection

Sent from my Nexus 7
Programming is a race between engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning
 
dafater
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2012
Quote:
Originally Posted by Captain Sweatpants View Post
If you are able to test multiple screens and ribbons with no effect then I would say your problem is the motherboard connection

Sent from my Nexus 7
I haven't test it with another cable, it's in the mail though. I really hope it's just the cable, cause I just got the replacement screen
 
Captain Sweatpants
Old
#4  
Captain Sweatpants's Avatar
Senior Member
Thanks Meter 83
Posts: 328
Join Date: Feb 2014
Location: Edinburgh
Quote:
Originally Posted by dafater View Post
I haven't test it with another cable, it's in the mail though. I really hope it's just the cable, cause I just got the replacement screen
It sounds like it will be the ribbon then they are very fragile it would be unusual to damage the motherboard connection

Sent from my C5303 using XDA Free mobile app
Programming is a race between engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning
 
dafater
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2012
Quote:
Originally Posted by Captain Sweatpants View Post
It sounds like it will be the ribbon then they are very fragile it would be unusual to damage the motherboard connection

Sent from my C5303 using XDA Free mobile app
the cable just arrived. I am very relieved to say that my stupidity only damaged the cable.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes