Enable the Hidden Notification LED on the Google Nexus 6!

LED notification lights have existed on Android devices since the very beginnings … more

MX Player Ready to Rock on Lollipop

A good video player should be reliable and free. One of the XDA Community Apps, MX Player, meets both of … more

How to Disable Data Encryption on Nexus 6

In late September, Google decided to step on NSA’s toes and turn on encryption by default in … more

DJI Phantom 2 Vision+ Review – XDA TV

The holidays will be here in no time, so why not start thinking about gifts now? Youll be ahead … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[GUIDE] S4 Proximity Sensor Fix (Blank Screen During Calls)

OP dagentooboy

4th June 2014, 10:51 PM   |  #1  
dagentooboy's Avatar
OP Senior Member
Flag Kansas
Thanks Meter: 135
 
516 posts
Join Date:Joined: Feb 2008
More
I am trying to keep this guide in one place. It is a simple fix! Instructions here

Please post if it works for you!
The Following User Says Thank You to dagentooboy For This Useful Post: [ View ]
7th June 2014, 10:00 PM   |  #2  
apbms1's Avatar
Junior Member
Thanks Meter: 4
 
12 posts
Join Date:Joined: Nov 2012
Just done mine and it works perfectly now. Many thanks.

Sent from my GT-I9505 using Tapatalk 2
9th June 2014, 08:46 PM   |  #3  
tommyW89's Avatar
Junior Member
Thanks Meter: 1
 
11 posts
Join Date:Joined: Oct 2010
More
It dont work for me! Still stays black.

Skickat från min GT-I9505G via Tapatalk
9th June 2014, 09:00 PM   |  #4  
dagentooboy's Avatar
OP Senior Member
Flag Kansas
Thanks Meter: 135
 
516 posts
Join Date:Joined: Feb 2008
More
Quote:
Originally Posted by tommyW89

It dont work for me! Still stays black.

Skickat från min GT-I9505G via Tapatalk

What was the value before you applied the calibration?
9th June 2014, 11:03 PM   |  #5  
tommyW89's Avatar
Junior Member
Thanks Meter: 1
 
11 posts
Join Date:Joined: Oct 2010
More
Between 40-50

Skickat från min GT-I9505G via Tapatalk
10th June 2014, 02:27 PM   |  #6  
dagentooboy's Avatar
OP Senior Member
Flag Kansas
Thanks Meter: 135
 
516 posts
Join Date:Joined: Feb 2008
More
Quote:
Originally Posted by tommyW89

Between 40-50

Skickat från min GT-I9505G via Tapatalk

That's where mine was. Make sure you have root, get the permissions reset properly, and reboot to load the configuration. You can probably just copy and paste the commands in the OP (do su first and make sure you allow it).
15th June 2014, 06:02 AM   |  #7  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Mar 2014
More
This guide solve my problem.
I noticed about the problem when flashed AOSP based Rom. So, thinked it was a rom bug.
Then, flashed stock again and find the issue was still there.
After trying whit compressed air, and nothing changes, rooted my phone (again) and follow this guide, and proximity sensor is working again.
Thanks.

Enviado desde mi GT-I9500 mediante Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes