Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,054 Members 40,747 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem With APN/Mobile Data on XT926

Tip us?
 
mball567
Old
(Last edited by mball567; 6th June 2014 at 03:30 AM.) Reason: spelling
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jun 2013
Default [Q] Problem With APN/Mobile Data on XT926

The other day I was on my Razr HD and the mobile data stopped working. This has happened before so i went down the list of checking if my data was set to on, airplane mode was off, etc. Everything was how it should be, and I still cant use my mobile data. The only time the 4G logo shows up is when I am connected to a wifi network, and when I turn wifi off, the logo goes away. In the status settings it shows my Mobile Network State as disconnected. I searched the forums and saw something about making a new APN, or editing an existing one, but it wont let me edit the APNs and there is no option to make a new APN. As a last resort I did a factory reset of the phone, and the problem is still happening. Does anyone have a clue what is going on?
 
cmh714
Old
#2  
Member
Thanks Meter 13
Posts: 74
Join Date: Jul 2009
You can try Tweakker in the play store....there are others as well
 
mball567
Old
(Last edited by mball567; 6th June 2014 at 05:32 AM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jun 2013
Quote:
Originally Posted by cmh714 View Post
You can try Tweakker in the play store....there are others as well
I have tried that but to get it it to work i need to make a new APN, and phone doesnt display that option anywhere. The only option it has is "reset to default"
 
Playb3yond
Old
#4  
Senior Member
Thanks Meter 6
Posts: 112
Join Date: Dec 2012
Just use House of Moto and flash with the keepdata script
 
St.Noigel
Old
(Last edited by St.Noigel; 6th June 2014 at 12:39 PM.)
#5  
St.Noigel's Avatar
Senior Member
Thanks Meter 120
Posts: 527
Join Date: Mar 2013
Location: Ivano-Frankivsk
Quote:
Originally Posted by mball567 View Post
The other day I was on my Razr HD and the mobile data stopped working. This has happened before so i went down the list of checking if my data was set to on, airplane mode was off, etc. Everything was how it should be, and I still cant use my mobile data. The only time the 4G logo shows up is when I am connected to a wifi network, and when I turn wifi off, the logo goes away. In the status settings it shows my Mobile Network State as disconnected. I searched the forums and saw something about making a new APN, or editing an existing one, but it wont let me edit the APNs and there is no option to make a new APN. As a last resort I did a factory reset of the phone, and the problem is still happening. Does anyone have a clue what is going on?
I had the same issues on official 4.4.2 (XT907 - Razr M)
I fix it with replacing APNS.CONF (*/system/etc)
I took APNS.CONF from KitStalk (AOSP-based ROM)

To this way you need to have root-access

You can try attached APNS.CONF
Don`t forget to backup original file!
Good luck!
Attached Files
File Type: rar apns-conf.rar - [Click for QR Code] (25.1 KB, 12 views)
Motorola Droid Razr M XT907 / Unlocked
ROM: Testing everything & everyday
GSM / Kyivstar / Ukraine
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes