Post Reply

[Q]Android OS

OP vangeodee

5th June 2014, 07:12 AM   |  #1  
OP Senior Member
Flag Birth: Cebu, Current: Puerto Princesa
Thanks Meter: 20
 
118 posts
Join Date:Joined: Sep 2012
More
Last night, around 2am, I unplugged my phone from the charger before i went to sleep (it had WiFi on) and now when I woke up and checked it at 1:30pm the next day, I had 35% battery left! WHAT!? checked battery stats and Android OS ate up 51%! with phone idle at 12%

anyone have any idea what's going on? I have everything except WiFi turned off, GPS, Location Services, Auto-Sync, Auto-Backup, everything. I also underclocked everything via cpu master and trickster mod. I greenified facebook, viber, skype and any other app that could potentially wake my phone from deep sleep.

I checked trickster mod, deep sleep was at around 5hrs with 162mhz at around 7hrs. don't have any screenies of those since I rebooted my device right after I plugged in the charger (helps with displaying correct percentage)

I've attached a screenshot. I've never seen that kind of downar plunge in my battery stats. ever. this is the first time it's ever happened.

I'll install wakelock detector and give it a few hours. I know my phone drains around 1%/hr while idle, maybe even less.


EDIT: I already started when I took the second screenshot. I forgot to take a screenshot of the rest of my battery stats. so don't mind the time and the difference in battery percentage.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-06-05-13-45-40.png
Views:	51
Size:	107.3 KB
ID:	2781509   Click image for larger version

Name:	Screenshot_2014-06-05-14-16-05.png
Views:	40
Size:	172.3 KB
ID:	2781522  
Last edited by vangeodee; 5th June 2014 at 07:22 AM.
5th June 2014, 08:47 AM   |  #2  
Senior Member
London
Thanks Meter: 32
 
282 posts
Join Date:Joined: Aug 2010
More
that's kernel problem. I meet that problem before, while I'm using AK-kernel with Vanir ROM. Kernel make screen always on to increase respond for S2W and Double Tap to Wake, but also cause this problem. In Android 4.4.2 also have this issues ( Nexus 4 and Nexus 5 is an example, you can search Google for this ).

You can install Better Battery Stats to check wakelock issues, but you can't do nothing, unless you have to changed to another kernel
Last edited by BIBUBO BCJ; 5th June 2014 at 08:50 AM.
5th June 2014, 11:05 AM   |  #3  
OP Senior Member
Flag Birth: Cebu, Current: Puerto Princesa
Thanks Meter: 20
 
118 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by BIBUBO BCJ

that's kernel problem. I meet that problem before, while I'm using AK-kernel with Vanir ROM. Kernel make screen always on to increase respond for S2W and Double Tap to Wake, but also cause this problem. In Android 4.4.2 also have this issues ( Nexus 4 and Nexus 5 is an example, you can search Google for this ).

You can install Better Battery Stats to check wakelock issues, but you can't do nothing, unless you have to changed to another kernel

don't have S2W and knock on enabled on my kernel. I also tried those and their battery drain is nothing compared to this!

I've charged my device and now it's showing Google Search as the culprit. now looking for a solution.
5th June 2014, 12:21 PM   |  #4  
Senior Member
London
Thanks Meter: 32
 
282 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by vangeodee

don't have S2W and knock on enabled on my kernel. I also tried those and their battery drain is nothing compared to this!

I've charged my device and now it's showing Google Search as the culprit. now looking for a solution.

what's your kernel ?
5th June 2014, 12:36 PM   |  #5  
OP Senior Member
Flag Birth: Cebu, Current: Puerto Princesa
Thanks Meter: 20
 
118 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by BIBUBO BCJ

what's your kernel ?

Solid Kernel + Stock 4.1.2 with a few xposed modules. I've solved the problem. Had to completely turn off Google Now and blocked wakelocks from Google Play Services.

I'll give this 3 hours and see if it goes back to the 1%-1hr idle drain. Battery stats seems to have improved, I'll post my post-fix battery stats in around 5 hours just to check if the problem comes back.
6th June 2014, 06:09 PM   |  #6  
OP Senior Member
Flag Birth: Cebu, Current: Puerto Princesa
Thanks Meter: 20
 
118 posts
Join Date:Joined: Sep 2012
More
aaaaaaaaaaand it's back. This time it's not Android OS but Google Play Services that's eating the battery up. I now get 2%/hr with this new problem.

I checked trickster mod and my phone is not entering deep sleep. checked wakelock detector and it showed GCMSEND as keeping the phone awake. (1h 52m out of 2h)

Anyone know a fix for this? I've currently filtered it in Wakelock Terminator and I'll see how it goes from there.

UPDATE:

22 mins in and phone is in Deep Sleep 84% of the time. filtered GCMSEND and added 2 lines to build.prop that supposedly improves deep sleep.

ro.ril.disable.power.collapse=1
pm.sleep_mode=1

Source: http://forum.xda-developers.com/show...22&postcount=2

Will leave it overnight to see if it stays this way.
Last edited by vangeodee; 6th June 2014 at 06:47 PM.
7th June 2014, 04:38 AM   |  #7  
Senior Member
London
Thanks Meter: 32
 
282 posts
Join Date:Joined: Aug 2010
More
yeah, noway to fix it because it was an issues of kernel.

If GCMSEND always running, you can downlod app called Disable Services, and Open it to disable some service in Google Play Store and another system app. Try it and will see if it's working.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Optimus G Q&A, Help & Troubleshooting by ThreadRank