FORUMS

Galaxy S6 Weekly Shooting Challenge

Over in our forums this weekend, XDA Forum member DevonSloan has started a thread for talented … more

Which Features from Apple Watch Do You Think Android Wear Will Copy?

The Apple Watch and Android Wear are both growing platforms. Now … more

XDA Picks: Best Apps of the Week (May 15 – 22)

Apps are at the front and center of any smartphone experience, and with over a … more

Android 5.1 for the Nvidia Shield Tablet is Out!

Nvidia is quite good at delivering updates in a timely fashion. The producer of famous … more
Post Reply Subscribe to Thread Email Thread

[Q] My Galaxy Mega won't startup

2nd June 2014, 05:35 PM |#1  
OP Junior Member
Flag Ankara
Thanks Meter: 0
 
Donate to Me
More
Hey mates. I've updated my phone to the Russian KitKat firmware today. First it opened perfectly fine. Then I wanted to switch off to do the wipe cache and wipe data thing. I've pressed the combination volume up + home + power and the screen lighten up but after approximately 5 seconds, the phone switched off. Then I pressed off and it stucked on the Samsung screen. I couldn't switch it off and pulled out the battery. Tried to go into Odin mode, but same thing happened. Then I recharged it to full, but still the same. I can't format the phone, nor open it. Can anybody help me? Thank you very much.
 
 
5th June 2014, 08:21 PM |#2  
Junior Member
Flag Warsaw
Thanks Meter: 0
 
More
Phone switching off even in download mode?

Wysłane z mojego GT-I9205 przy użyciu Tapatalka
6th June 2014, 02:29 PM |#3  
Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by cortex47

Hey mates. I've updated my phone to the Russian KitKat firmware today. First it opened perfectly fine. Then I wanted to switch off to do the wipe cache and wipe data thing. I've pressed the combination volume up + home + power and the screen lighten up but after approximately 5 seconds, the phone switched off. Then I pressed off and it stucked on the Samsung screen. I couldn't switch it off and pulled out the battery. Tried to go into Odin mode, but same thing happened. Then I recharged it to full, but still the same. I can't format the phone, nor open it. Can anybody help me? Thank you very much.

Hey mate, did you ever fix your problem?
6th June 2014, 03:59 PM |#4  
starmaster10's Avatar
Senior Member
Flag Saskatoon
Thanks Meter: 253
 
More
Quote:
Originally Posted by cortex47

Hey mates. I've updated my phone to the Russian KitKat firmware today. First it opened perfectly fine. Then I wanted to switch off to do the wipe cache and wipe data thing. I've pressed the combination volume up + home + power and the screen lighten up but after approximately 5 seconds, the phone switched off. Then I pressed off and it stucked on the Samsung screen. I couldn't switch it off and pulled out the battery. Tried to go into Odin mode, but same thing happened. Then I recharged it to full, but still the same. I can't format the phone, nor open it. Can anybody help me? Thank you very much.

You will have to re-install the rom as by wiping the data that is important to the running of the rom, you wipe the Cache and the Dalvik cache only, if you can get to the download mode (odin mode) then reflash the rom, try that same button combo with the phone powered off first and see if you can get into the download mode.
Last edited by starmaster10; 6th June 2014 at 04:04 PM.
7th June 2014, 10:24 AM |#5  
OP Junior Member
Flag Ankara
Thanks Meter: 0
 
Donate to Me
More
Update: I have applied the USB Jig solution. The phone got into Odin Mode, but it didn't show up on the screen. The screen was black (shiny black, I knew it was on), but Odin recognized the phone. Then I reflashed the ROM, the phone restarted but it stuck on the SAMSUNG screen, however Odin said PASS. So I have gone back to square one. I still can't use the three buttons to get into Odin or Recovery Modes. I only can use USB Jig but this happens. I can't wipe data or cache. And after this operation, now my phone charges, but it doesn't show up on the screen and the notification lights don't work like it used to. What should I do know? It's clearly a software problem, but I have no idea about what to do next.
7th June 2014, 11:41 AM |#6  
OP Junior Member
Flag Ankara
Thanks Meter: 0
 
Donate to Me
More
Quote:
Originally Posted by BoiBundy

Hey mate, did you ever fix your problem?

nope
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes