Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,034 Members 47,282 Now Online
XDA Developers Android and Mobile Development Forum

Galaxy S4 : Weird issue with magnetic sensor when mobile data is on

Tip us?
 
Th3DON
Old
#1  
Th3DON's Avatar
Senior Member - OP
Thanks Meter 104
Posts: 258
Join Date: Mar 2013
Location: Ernakulam

 
DONATE TO ME
Exclamation Galaxy S4 : Weird issue with magnetic sensor when mobile data is on

Hi Folks,

I have got a strange issue. First let me tell my story. My phone was fallen down 2 weeks before and the screen was broken but the functionality wise(including mobile data), phone was good. After 4 days, i replaced the screen from customer care, after that my sim card was not getting any signals. then i gave back to customer care and they fixed the problem with in 5 minutes. (On the same day night, my phone was fallen again to water, fortunately nothing happened, only the speaker was acting weird, it went OK after sometime)

Here the problem part starts, after the screen replacement, for the first time i turned on the mobile data on my phone. then magnetic sensor weird issue started. When the mobile data is on, the phone feels some magnetic noise and the S view cover display will flash through screen. This will happen like once in few minutes or in a such gap. it will just flash for 1 sec and go. When the mobile data is OFF/ in the flight mode, the issue never occurs. Any idea on this

I ran few tests, the results are in the attachment, i changed SIM and the behavior is same.
When i contacted the customer care, they said they have seen this issue and they can make it good by installing fresh s/w again. But my phone is out of warranty(so i need me pay for this) and i already tried cleaning my phone, wiping everything, installing fresh ROM's..
But nothing does the job
Attached Thumbnails
Click image for larger version

Name:	2014-05-17 10.21.14.png
Views:	26
Size:	146.1 KB
ID:	2748086   Click image for larger version

Name:	Screenshot_2014-05-17-10-16-30.png
Views:	22
Size:	34.8 KB
ID:	2748087  
 
Th3DON
Old
#2  
Th3DON's Avatar
Senior Member - OP
Thanks Meter 104
Posts: 258
Join Date: Mar 2013
Location: Ernakulam

 
DONATE TO ME
The issue is resolved by installing the latest Black edition firmware (from Samsung service center)
 
Th3DON
Old
#3  
Th3DON's Avatar
Senior Member - OP
Thanks Meter 104
Posts: 258
Join Date: Mar 2013
Location: Ernakulam

 
DONATE TO ME
iSsue is coming again, s view is flashing when i am on a call or mobile data is on.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes