Vikaura Screen: Use Your Android to Customize Your World

Vikaura is another hot Kickstarter item building momentum online. This time the idea … more

Neon’s Colors Theme For Android L

This CyanogenMod 12 theme by XDA Recognized Themernitinvaidbrings some really nice looking colors to … more

Galaxy Note Edge Panel Themes

Follow this link to find themes from your favorite sports teams, video games, companies, and more for your lock … more

Official MEGA Layers Overlays Collection

The Layers Overlays is getting more popular every day and is a nice alternative to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Wifi auto connect to AT&T public wifi - how to disable this?

OP inspron

6th June 2014, 09:16 PM   |  #1  
OP Senior Member
Flag San Diego, CA
Thanks Meter: 45
 
223 posts
Join Date:Joined: Apr 2008
More
I have the T-mobile LG G2 D801. Every time I am near an AT&T wifi hotspot, my phone "knows" my location and automatically turn on the wifi and connect to it, even skipping the usual web login agreement. This is the first time I have seen this feature on a none-AT&T phone. Has anyone else notice this?

Very interesting ability but how does my phone knows I am near the AT&T wifi when my wifi is already set to off?

How do I disable this feature (none-rooted phone).
6th June 2014, 11:52 PM   |  #2  
Senior Member
Thanks Meter: 54
 
223 posts
Join Date:Joined: Nov 2012
More
I haven't noticed this on mine; I'll have to watch for it. There is a "scanning always available" setting in the Advanced Wi-Fi settings, it is enabled on my phone.
7th June 2014, 12:05 AM   |  #3  
OP Senior Member
Flag San Diego, CA
Thanks Meter: 45
 
223 posts
Join Date:Joined: Apr 2008
More
Quote:
Originally Posted by diamond12

I haven't noticed this on mine; I'll have to watch for it. There is a "scanning always available" setting in the Advanced Wi-Fi settings, it is enabled on my phone.

Yes, this feature was turned off and my phone still automatically detects I am near a Starbucks and connect to the wifi there.
7th June 2014, 04:26 AM   |  #4  
Senior Member
Flag Texas
Thanks Meter: 109
 
379 posts
Join Date:Joined: Dec 2013
More
Do you have snapdragon battery guru installed?
7th June 2014, 07:12 PM   |  #5  
OP Senior Member
Flag San Diego, CA
Thanks Meter: 45
 
223 posts
Join Date:Joined: Apr 2008
More
Quote:
Originally Posted by Swizzle82

Do you have snapdragon battery guru installed?

I do not
7th June 2014, 08:21 PM   |  #6  
Senior Member
Flag Texas
Thanks Meter: 109
 
379 posts
Join Date:Joined: Dec 2013
More
I ask because it manages your wifi and can turn it on automatically good app though. Idk what your issue might be then, I've never had an issue like that.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes