Post Reply

[Q] Display problem on xperia Tx

OP daniel090588

7th June 2014, 08:11 PM   |  #1  
OP Senior Member
Thanks Meter: 14
 
106 posts
Join Date:Joined: Feb 2011
Well i hope i can find a solution here so this is what hapenned. My Tx went swimming i left it aroud the bath tub and someone was calling me but it was on vibracall so i didinīt listen it, then it fall into the water but i saw it and as fast as i could i take out of the water and it was still ringing, but the very first thing i dit was take out the battery and the screen was still visible when i dit that, it was also vibrating untill i take off the battery so, i disasemble it and take out all the parts to dry them with a hair blower, then put it all back together. Well the cellphone turns on and it works as normal but screen is black, i mean only backlight is on but with no video at all,

so i conect it to my tv using an mhl adapter and all the info is on the tv i mean i hav image on the tv but not on the cellphone, i try the display with another motherboard of a damaged tx that i bought and found that the display works well on the other cellphone but not in mine so the problem must be on the motherboard of my cell i guess i hope someone can help me with this.
8th June 2014, 12:10 AM   |  #2  
neosnake991's Avatar
Senior Member
Flag Bargoed
Thanks Meter: 69
 
144 posts
Join Date:Joined: Feb 2011
Donate to Me
More
wow less is more lol, I'm going to suggest a stupid but most probably, the correct solution, recheck the cables inside the phone and make sure they ain't broke, or are in tidy

Sent from my Xperia T using Tapatalk
The Following User Says Thank You to neosnake991 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia T, TL, TX, V Q&A, Help & Troubleshooting by ThreadRank