Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,914 Members 49,587 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Need advice, new display/digitizer assembly issue

Tip us?
 
feelx77
Old
(Last edited by feelx77; 8th June 2014 at 01:28 AM.) Reason: typos
#1  
feelx77's Avatar
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Aug 2010
Location: Katy
Default [Q] Need advice, new display/digitizer assembly issue

Kind of stumped and wanted to get others opinions on the matter or if compatibility issue etc.

I have an original all white 16gb T-Mobile non-LTE T999 Galaxy S3. Well after many bezel cracks and screen wear and menu button going out I decided to rebuild the phone and remodel different color. So I purchased everything in black and red.

I picked up a fully pre-assembled new Garnet Red Display/Digitizer assembly received it yesterday. I swapped the assembly and re-assembled phone. Turned on fine but would hang. Triple checked all contacts and assembly and still always turned on but hung.....eventually it always boots but the touch or digitizer isn't there. There's no touch screen response at all. Once I realized it just stalls, it actually always boots but takes longer and never has any touch screen response but looks normal.

I plugged th old screen on the main board in white and it works and boots fine. I go into CWM recovery and do key tests and all keys work and shows key test results when tapping the touch screen. Turn it off and plug back in new Red display and display looks great but no key test read outs in CWM when tapping the screen. All buttons give same key test readouts as white display.

So basically my new replacement display/digitizer assembly in red to replace my white has no touch ability or response and causes slow boot or boot hang. Other than that both displays look EXACTLY the same and have the same pre-etched factory numbers on back where battery would go "T999/I747"

So is it a display firmware issue you think or possible bad new display assembly I received? Product looked brand new with no scratches and still had factory sticker wrap on it like when I received my phone brand new. Looks great and would be nice if I could get it to work.

If there are no known compatibility issues than I will ask for an exchange from the seller. Looking for recommendations/opinions. I picked it up from this listing here:

http://www.ebay.com/itm/271490581584...84.m1439.l2649
 
tokenpoke
Old
#2  
Senior Member
Thanks Meter 100
Posts: 513
Join Date: Apr 2011
Sounds like a faulty display causing issues with drivers.

Sent from my SGH-T999 using Tapatalk
 
feelx77
Old
#3  
feelx77's Avatar
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Aug 2010
Location: Katy
Quote:
Originally Posted by tokenpoke View Post
Sounds like a faulty display causing issues with drivers.

Sent from my SGH-T999 using Tapatalk
Also, just to clarify. Touch doesn't work in CWM Touch Recovery or give key test readouts for screen on Garnet Red display. Touch works fine and gives readouts on original White in CWM Touch Recovery.

So, once seller receives my messages Monday morning maybe lean on exchange if everyone thinks it should just work? Will wait and see weekend responses and feedback.
 
tokenpoke
Old
#4  
Senior Member
Thanks Meter 100
Posts: 513
Join Date: Apr 2011
Yeah, its should be working without issue. I'm guessing there's a flaw in the digitizer causing interface issues.

Sent from my SGH-T999 using Tapatalk
 
feelx77
Old
#5  
feelx77's Avatar
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Aug 2010
Location: Katy
Quote:
Originally Posted by tokenpoke View Post
Yeah, its should be working without issue. I'm guessing there's a flaw in the digitizer causing interface issues.

Sent from my SGH-T999 using Tapatalk
Sounds good so far than. Been driving me bonkers since last night. Plus time consuming to fully disassemble the phone and rebuild with breaking losing screws...lol. So ready to have it up and running but just goign to have to wait for an exchanged display than. Was all excited when I powered it on last night only for it to sit there forever before booting and not respond to touch. Smile turned to frown.

Was actually going to get the HTC One M8 but decided last minute to save the money and get more mileage out of this phone. Have really liked it and with CM11 and tweaks more than happy with it for another year or two. Just figured before I'd drop $600+, just fix & clean up my phone for now.
 
feelx77
Old
#6  
feelx77's Avatar
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Aug 2010
Location: Katy
Received replacement display/digitizer today and it worked like a charm. No issues. So first one sent was a lemon, defective. Just wanted to update in case someone else has a similar issue. Thanks for those that gave opinions/help.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Rir Yourself Charging Annoyances with No Wake on Charge Xposed Module

Almost every OEM has skinned and otherwise modifiedAndroid to suit its … more

Run, Jump, and Shoot in Tales of Ciaxia

There are certain types of games that have become paramount of the portable gaming world. As we have … more