DJI Phantom 2 Vision+ Review – XDA TV

The holidays will be here in no time, so why not start thinking about gifts now? Youll be ahead … more

Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Detect, Avoid IMSI-Catcher Attacks with Android IMSI-Catcher Detector

Privacy is always an important topic, as well as a delicate one to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

[Q] Need advice, new display/digitizer assembly issue

OP feelx77

Prev Previous Post   Next Post Next
8th June 2014, 02:23 AM   |  #1  
feelx77's Avatar
OP Member
Flag Katy
Thanks Meter: 0
 
33 posts
Join Date:Joined: Aug 2010
Kind of stumped and wanted to get others opinions on the matter or if compatibility issue etc.

I have an original all white 16gb T-Mobile non-LTE T999 Galaxy S3. Well after many bezel cracks and screen wear and menu button going out I decided to rebuild the phone and remodel different color. So I purchased everything in black and red.

I picked up a fully pre-assembled new Garnet Red Display/Digitizer assembly received it yesterday. I swapped the assembly and re-assembled phone. Turned on fine but would hang. Triple checked all contacts and assembly and still always turned on but hung.....eventually it always boots but the touch or digitizer isn't there. There's no touch screen response at all. Once I realized it just stalls, it actually always boots but takes longer and never has any touch screen response but looks normal.

I plugged th old screen on the main board in white and it works and boots fine. I go into CWM recovery and do key tests and all keys work and shows key test results when tapping the touch screen. Turn it off and plug back in new Red display and display looks great but no key test read outs in CWM when tapping the screen. All buttons give same key test readouts as white display.

So basically my new replacement display/digitizer assembly in red to replace my white has no touch ability or response and causes slow boot or boot hang. Other than that both displays look EXACTLY the same and have the same pre-etched factory numbers on back where battery would go "T999/I747"

So is it a display firmware issue you think or possible bad new display assembly I received? Product looked brand new with no scratches and still had factory sticker wrap on it like when I received my phone brand new. Looks great and would be nice if I could get it to work.

If there are no known compatibility issues than I will ask for an exchange from the seller. Looking for recommendations/opinions. I picked it up from this listing here:

http://www.ebay.com/itm/271490581584...84.m1439.l2649
Last edited by feelx77; 8th June 2014 at 02:28 AM. Reason: typos
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes