Post Reply

Unable to cast netflix

6th June 2014, 04:31 AM   |  #11  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Sep 2010
I tested chromecast connecting to my phone in tethering mode. Netflix worked everytime. But when I got back to my regular connection, the problem appeared again.

So the problem seems to be located in my cable modem that also is a router.

Sent from my HTC One_M8 using XDA Free mobile app
6th June 2014, 05:52 AM   |  #12  
Senior Member
Thanks Meter: 307
 
1,803 posts
Join Date:Joined: Dec 2007
Ok first question...do you have another router connected to the Modem Router? Are you using the Modem's built in WiFi or this other router's?

If you have another router then chances are likely you have a double NAT situation which is messing you up.

Check your other router and see what IP address is has listed under Internet connection...If it is a 192.168.xxx.xxx then it's a double Nat and you need to call your Cable company and have them put the Modem into Bridge mode.

If you do not have another router and use only the Modem router then you need to call the cable company and have them change the settings on the router to allow multicast and UPnP...Maybe a few other settings as well. Tell them what you are trying to do they have probably gotten lots of calls from others with the same issue.

Me personally I prefer to use my own router and have them put the Modem into Bridge mode so I have full control over the network and don't need to call them whenever I have a problem or want to change settings.
The Following User Says Thank You to Asphyx For This Useful Post: [ View ]
6th June 2014, 02:44 PM   |  #13  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by Asphyx

Ok first question...do you have another router connected to the Modem Router? Are you using the Modem's built in WiFi or this other router's?

If you have another router then chances are likely you have a double NAT situation which is messing you up.

Check your other router and see what IP address is has listed under Internet connection...If it is a 192.168.xxx.xxx then it's a double Nat and you need to call your Cable company and have them put the Modem into Bridge mode.

If you do not have another router and use only the Modem router then you need to call the cable company and have them change the settings on the router to allow multicast and UPnP...Maybe a few other settings as well. Tell them what you are trying to do they have probably gotten lots of calls from others with the same issue.

Me personally I prefer to use my own router and have them put the Modem into Bridge mode so I have full control over the network and don't need to call them whenever I have a problem or want to change settings.


My cable modem a public IP provided by my ISP, and a private IP that is 192.168.0.1. My router has a WAN IP provided by my cable modem (192.168.0.xxx) and a LAN IP 192.168.1.1. My chromecast used to be connected in my router LAN, but I changed it to connect directly to the cable modem router. I'll try to put the cable modem in bridge mode to see what happens as I have full access to its configuration.

Thanks again
6th June 2014, 07:39 PM   |  #14  
Senior Member
Thanks Meter: 307
 
1,803 posts
Join Date:Joined: Dec 2007
Quote:
Originally Posted by luizm.jr

My cable modem a public IP provided by my ISP, and a private IP that is 192.168.0.1. My router has a WAN IP provided by my cable modem (192.168.0.xxx) and a LAN IP 192.168.1.1. My chromecast used to be connected in my router LAN, but I changed it to connect directly to the cable modem router. I'll try to put the cable modem in bridge mode to see what happens as I have full access to its configuration.

Thanks again

Yep that setup causes a double Nat situation Which doesn't work well for most networking applications....
Especially since you are also dealing with Two different Wireless networks.

Best setup is to have the modem just be a modem and send public IPs to whatever connects to it.
Then you won't have any Nat translation issues PLUS you get the ability (if your Modem has multiple ports like most Modem/Router Hybrids do, You can get a public IP for any device directly connected to the Modem which is good for running servers and for testing router issues.
The Following User Says Thank You to Asphyx For This Useful Post: [ View ]
7th June 2014, 06:39 PM   |  #15  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Sep 2010
Problem solved!

I turned off the wifi on the cable modem and put it on bridge mode, letting my router deal with my network. Netflix is now working good on both chromecast and Google tv.

However I believe the problem was related to a still unknown setting in the cable modem as I left it operating alone and netflix was still not able to load.

Thank you very much for the help. I really appreciate it.

Sent from my HTC One_M8 using XDA Free mobile app
8th June 2014, 03:26 AM   |  #16  
Senior Member
Thanks Meter: 307
 
1,803 posts
Join Date:Joined: Dec 2007
Quote:
Originally Posted by luizm.jr

Problem solved!

I turned off the wifi on the cable modem and put it on bridge mode, letting my router deal with my network. Netflix is now working good on both chromecast and Google tv.

However I believe the problem was related to a still unknown setting in the cable modem as I left it operating alone and netflix was still not able to load.

Thank you very much for the help. I really appreciate it.

Sent from my HTC One_M8 using XDA Free mobile app

it may very well have been a Router issue with the Modem...But now that it is only a Bridge the other router's settings will handle all the communication needed for the CCast and it should work...
As long as the settings on the second router were not the issue in the first place.
The Following User Says Thank You to Asphyx For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Google Chromecast by ThreadRank