Post Reply

[Q] Is it necessary for my m7 to be S-Off before I can flash the latest ViperOne Rom?

OP iamdecaf

8th June 2014, 02:53 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
My m7 is rooted and has the bootloader unlocked already. But it's still S-On and running hboot version 1.57. I'm worried that flashing the latest ViperOne ROM that has hboot version 1.54 will brick it. So I'm wondering if it is needed for my m7 to be s-off before i can flash the ROM. Any help would be greatly appreciated. Thank you.
8th June 2014, 04:54 AM   |  #2  
clsA's Avatar
Senior Member
Flag Central Florida
Thanks Meter: 1,081
 
3,992 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by iamdecaf

My m7 is rooted and has the bootloader unlocked already. But it's still S-On and running hboot version 1.57. I'm worried that flashing the latest ViperOne ROM that has hboot version 1.54 will brick it. So I'm wondering if it is needed for my m7 to be s-off before i can flash the ROM. Any help would be greatly appreciated. Thank you.

Rom's don't have a hboot
all that's important is you have TWRP Recovery v2.6.3.3 or up and your on a M7_u or M7_UL

S-off is always good but your already hboot 1.57 so it might be a challenge
The Following User Says Thank You to clsA For This Useful Post: [ View ]
8th June 2014, 05:03 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
Quote:
Originally Posted by clsA

Rom's don't have a hboot
all that's important is you have TWRP Recovery v2.6.3.3 or up and your on a M7_u or M7_UL

S-off is always good but your already hboot 1.57 so it might be a challenge

I'm using CWM v6.0.4.6, but I suppose as long as I have a recovery flashed I should be alright right? And yes I'm on m7_UL. Thanks a lot for your reply!
8th June 2014, 05:12 AM   |  #4  
clsA's Avatar
Senior Member
Flag Central Florida
Thanks Meter: 1,081
 
3,992 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by iamdecaf

I'm using CWM v6.0.4.6, but I suppose as long as I have a recovery flashed I should be alright right? And yes I'm on m7_UL. Thanks a lot for your reply!

no, older recovery's have problems with the newer Rom's

update to TWRP
http://techerrata.com/browse/twrp2/m7

fastboot flash recovery openrecovery-twrp-2.6.3.3-m7.img
fastboot erase cache
fastboot reboot
8th June 2014, 05:37 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
Okay I've flashed Twrp v2.7.1.0. Now all I do is to flash the ROM itself right?
8th June 2014, 07:39 AM   |  #6  
Senior Member
Flag Melbourne
Thanks Meter: 97
 
583 posts
Join Date:Joined: Jul 2010
More
You can flash it. But as people have said twrp 2.6.3.3 is the best version to use. You can try the latest. If Rom won't boot flash the above recovery version

Sent from my HTC One using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes