Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,261 Members 51,452 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] - Xperia Z Ultra Poor Signal Reception Indoor

Tip us?
 
KyCeK
Old
#11  
KyCeK's Avatar
Junior Member
Thanks Meter 1
Posts: 6
Join Date: Mar 2014
Quote:
Originally Posted by neverborn View Post
Hi there - by antenna, do you mean the whitish cable on the right-most section of your picture?

Another thing, did the back cover stay attached perfectly after you've re-assembled it? I mean using the heat gun on it didn't make it permanently loose?

What about water-proofing?

Thanks!
Hi. Finally it's working and yes the cable was loose. It's really easy to open the phone. It's the cable on right it's grey and silver ( like on picture) You can buy new original adhesive tape on ebay for 5. I don't know about waterproofness after. I will try when I will get new phone. Hopefully ultra2

Sent from my C6833 using xda app-developers app
 
TheDiddlerMan
Old
#12  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Oct 2012
I'm surprised you'd even want a new one after dealing with that. Hopefully I don't need the original receipt to get warranty service. I hate the idea of opening up a new phone to solve a problem with a home remedy. As you can tell I am suffering from the same issue.
 
Triflot
Old
#13  
Senior Member
Thanks Meter 85
Posts: 136
Join Date: Sep 2011
3G and 4G can have poor reception indoors. See if switching to 2G only helps, even if you don't have mobile data enabled.
 
KyCeK
Old
#14  
KyCeK's Avatar
Junior Member
Thanks Meter 1
Posts: 6
Join Date: Mar 2014
It was the only way to normally use the phone. It took 5-10 min and now it's working perfect. Try with Sony service centre, I hope they will do it for you. It's best phone ever, I hope they will make ultra 2.

Sent from my C6833 using XDA Free mobile app
The Following User Says Thank You to KyCeK For This Useful Post: [ Click to Expand ]
 
gabriel1115
Old
#15  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2014
Default I have the same issue

Quote:
Originally Posted by Al3xxxinho View Post
Now I am using my sim card in a nexus 4 and i get full signal in the same place where my xperia doesn't.

The cell tower is not very far away ...

So, the house is not a problem ...

P.s : nexus 4 has full signal on wcdma but xperia has no signal/poor signal even on edge/gprs ...

As you can see in the picture, every phone tested with that sim has full signal in the same place. But not the xperia ... I think it's "blessed" ...

Sent from my Nexus 4 using Tapatalk 2
I have exactly the same issue
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes