Default Sero 7 Pro - won't boot

I have a Sero 7 Pro that has sero7pro-bld60220-dopa-v2.0 installed. It has been working fine for months until last night when I picked it up and it was powered off. It was plugged in to my PC usb port like I usually keep it so the battery should have been fully charged and I don't know why it powered itself off. Now it won't boot up. It sticks on the bootanimation screen. I tried to get into Fastboot using the volume/power button but it just hangs on the Fastboot screen and never goes any further. I am able to get into Recovery and have tried various options from just clearing cache and data to restoring the original OS using sideload and Adb on my PC. Nothing allows me to boot beyond the bootanimation. I have also tried to replace the bootanimation.zip file in the /system/media folder but it continues to try to boot with the same animation file. Is this somehow related or am I replacing the file in the wrong folder? Any ideas what might be wrong? How do I retrieve a log file to help diagnose the problem?