Post Reply

[Q] Problems after lcd replacement

OP cadshot21

8th June 2014, 11:38 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2013
So here is the story, I dropped my note 3 and the lcd crapped out, no big deal. I bought a whole new assembly because it was easier and quicker to replace. Everything went fine, phone fired up and the screen looks great, but now i do not have mobile connection. But to throw a monkey wrench into the equation, 4g data works, but no voice. Can't call at all and soon as I lose 4g, no mobile connection at all, no data or anything. Wifi works fine, everything else does also. So my question is what is going on. Could the drop have messed something up, the assembly swap, or anything you guys could think of. Any help or suggestions will be greatly appreciated. Thanks everyone.
9th June 2014, 01:01 PM   |  #2  
Senior Member
Thanks Meter: 377
 
1,637 posts
Join Date:Joined: Apr 2010
Quote:
Originally Posted by cadshot21

So here is the story, I dropped my note 3 and the lcd crapped out, no big deal. I bought a whole new assembly because it was easier and quicker to replace. Everything went fine, phone fired up and the screen looks great, but now i do not have mobile connection. But to throw a monkey wrench into the equation, 4g data works, but no voice. Can't call at all and soon as I lose 4g, no mobile connection at all, no data or anything. Wifi works fine, everything else does also. So my question is what is going on. Could the drop have messed something up, the assembly swap, or anything you guys could think of. Any help or suggestions will be greatly appreciated. Thanks everyone.

Did u get the right assembly? For Verizon? Not sure why it would matter, but read a similar thread before and the person had used a different assembly.

Sent from my SM-N900V using Tapatalk
10th June 2014, 04:51 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by mjh68

Did u get the right assembly? Verizon? Not sure why it would matter, but read a similar thread before and the person had used a different assembly.

Sent from my SM-N900V using Tapatalk

Yeah, it was for the Verizon, it looked exactly the same, I might swap everything back and try to call it and see if it works. Not sure yet.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Verizon Galaxy Note 3 Q&A, Help & Troubleshooting by ThreadRank