Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] After 4.4.3 Update GPS is super slow - Moto G MotoG

OP eckre

9th June 2014, 01:54 PM   |  #1  
OP Junior Member
Thanks Meter: 10
 
13 posts
Join Date:Joined: Jul 2011
So I updated to 4.4.3 on Friday the 6th, I use my Moto G's GPS all the time with My Tracks or Google Maps, and now after the update, it will not lock on to a GPS signal outside, even after 10 minutes. When I run My Tracks, it will almost lock up to a black screen after I turn on the GPS or start recording a track. It took 15 minutes for it to start recording this morning, outside. When I did turn it on outisde, it showed me about 2 miles away. Data and wifi was on and fully connected. I jiust want to post this here to see if anyone else is having GPS issues after the new 4.4.3 update.

Feel free to post details how to downgrade.
The Following User Says Thank You to eckre For This Useful Post: [ View ]
9th June 2014, 02:18 PM   |  #2  
Member
Thanks Meter: 24
 
99 posts
Join Date:Joined: Dec 2010
More
Did you factory reset after update ? I would advise you do that as it can cause some bugs, backup apps with titanium backup.
10th June 2014, 04:33 PM   |  #3  
OP Junior Member
Thanks Meter: 10
 
13 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by jikobutsu

Did you factory reset after update ? I would advise you do that as it can cause some bugs, backup apps with titanium backup.

You are 100% right! That cleared it right up.

And the restore process is also a lot better than I remember, I didn't have to do anything, it was great. Even my background pic came back.

thanks!
Post Reply Subscribe to Thread

Tags
gps issues, moto g, motog, slow gps
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes