Post Reply

[GUIDE] official cm11 RIL on williams kernel V2

7th June 2014, 08:34 AM   |  #1  
noahvt's Avatar
OP Senior Member
Thanks Meter: 315
 
1,134 posts
Join Date:Joined: Jan 2013
More
Hi guys,


Just a quick little guide on how to fix the wi-fi and bluetooth issues on the official cm11 nightlies!

You find the official cm11 a bit laggy? you thought it would be a great idea to install williams kernel V2? after installation you noticed that it runs so much better and are really happy with it till you notice that wi-fi and bluetooth aren't working? Well here is a simple fix for that!

Steps:

1: download these 2 files: https://www.mediafire.com/folder/4hs..._%26_Bluetooth (credit goes to @alcatraz999902)

2: navigate to system/lib/modules and delete wlan.ko and scsi_wait_scan.ko

3: copy the files you downloaded earlier (wlan.ko and scsi_wait_scan.ko) to system/lib/modules

4: change the permissions to rwrr:
A: you can use file explorers like es file explorer to change the perms (rwrr 644)
B: you can also open a terminal, mount your system as rw (mount -o rw,remount /system) and cd to /system/lib/modules then type these 2 commands:
chmod 644 wlan.ko
chmod 644 scsi_wait_scan.ko


5: reboot your device

6: Enjoy official cm nightlies with working wi-fi and bluetooth!
The Following 9 Users Say Thank You to noahvt For This Useful Post: [ View ]
7th June 2014, 01:45 PM   |  #2  
lanluckez's Avatar
Senior Member
Flag Madrid
Thanks Meter: 26
 
142 posts
Join Date:Joined: Mar 2009
More
Wow many thanks, mate!! I didn't know what was happening to the wifi. Now I can even solve it.

By the way, when you update a nightly, you need to readjust options like in built kernel mpdecision or reinstall optimized qcom's and all that stuff?

Cheers!
Last edited by lanluckez; 7th June 2014 at 01:56 PM.
7th June 2014, 02:14 PM   |  #3  
Member
Thanks Meter: 5
 
38 posts
Join Date:Joined: Oct 2013
More
It does not work CM11 Official
7th June 2014, 02:32 PM   |  #4  
Senior Member
Thanks Meter: 31
 
124 posts
Join Date:Joined: Apr 2013
it must work, you did mistake somewhere
7th June 2014, 02:46 PM   |  #5  
TsunaH's Avatar
Senior Member
Flag Paris
Thanks Meter: 56
 
364 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by zepp40

It does not work CM11 Official

It's actually work.
Read carefully what to do

Sent from me
7th June 2014, 03:27 PM   |  #6  
Senior Member
Thanks Meter: 48
 
105 posts
Join Date:Joined: Mar 2012
More
I suppose that's not a fix for wpa problems?
(since a long time, wifi doesn't work on WPA in cyanogenmod... only work with wep or wpa2)
But anyway, thanks for sharing


PS: Saloperie de freeboxV5.
10th June 2014, 01:02 PM   |  #7  
nplezka's Avatar
Senior Member
Flag Ascoli Piceno
Thanks Meter: 45
 
167 posts
Join Date:Joined: Jan 2012
More
What about new NyakKernel? I tried it but it doesn't work. Official CM, latest nightly.
10th June 2014, 03:13 PM   |  #8  
mykamran's Avatar
Senior Member
Thanks Meter: 28
 
360 posts
Join Date:Joined: Oct 2011
tnx so much

Sent from my Xperia SP using Tapatalk
10th June 2014, 03:21 PM   |  #9  
noahvt's Avatar
OP Senior Member
Thanks Meter: 315
 
1,134 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by nplezka

What about new NyakKernel? I tried it but it doesn't work. Official CM, latest nightly.

I think that kernel already has the correct modules

Sent from my Xperia SP using XDA Free mobile app
10th June 2014, 05:22 PM   |  #10  
Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: May 2013
When I install CM11 with Williams Kernel, the blue screen appear, no boot.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in Xperia SP General by ThreadRank