FORUMS

Help me with my rom pls!!!!!

117 posts
Thanks Meter: 11
 
By thecoolster, Senior Member on 7th June 2014, 11:20 AM
Post Reply Subscribe to Thread Email Thread
8th June 2014, 03:40 PM |#11  
demkantor's Avatar
Recognized Contributor
Flag mpls
Thanks Meter: 3,263
 
More
Thanks for supplying more information, now I have a better idea of how to help.
You should use the update-binary for your device, not the one ported,
All editing of the updater-script will need to be done in UNIX format, not windows as EOL differs, if your using windows be sure to use notepad++ and set it up properly,
I use 7zip normally not winrar but it shouldn't matter, you need to have compression set to store,
It has been years since I have tried to make a ROM in this fashion but I don't think much would have changed, the point your at now is to get it to flash (not get the ROM to work) this means you need to fix the status 7 error, which will be done by fixing your updater-script
If you want, post a copy of the meta-inf folder for your device and the one you are porting from an I can help further

Sent from my Nexus 7 using XDA Premium 4 mobile app
The Following User Says Thank You to demkantor For This Useful Post: [ View ]
 
 
8th June 2014, 06:46 PM |#12  
thecoolster's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 11
 
More
Thanks so much.......... Ur thnx meter is getting one more thanks
9th June 2014, 12:47 PM |#13  
thecoolster's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 11
 
More
Dude should I replace the whole Meta in folder or only the updater script....
9th June 2014, 02:14 PM |#14  
demkantor's Avatar
Recognized Contributor
Flag mpls
Thanks Meter: 3,263
 
More
Take a meta-inf for your device and replace the updater-script from the other one and swap it. Then you'll more than likely need to edit it to flash on yours

Sent from my Nexus 4 using XDA Premium 4 mobile app
10th June 2014, 05:04 PM |#15  
thecoolster's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 11
 
More
Sorry I didn't understand anything.... I just swapped the cm 11 meta inf file with the original meta inf file.....
Last edited by thecoolster; 10th June 2014 at 05:07 PM.
10th June 2014, 06:47 PM |#16  
demkantor's Avatar
Recognized Contributor
Flag mpls
Thanks Meter: 3,263
 
More
Well you can't do this, you need to have the update-binary for your device specifically and you need to edit the updater-script to work with yours as well.
So keep meta-inf specific for your device, and only swap updater-scripts, then you need to edit this updater-script to match the partitions of yours as well as make sure there aren't any get_props that conflict.
I highly suggest reading up on updater-scripts so you understand the changes that need to be made

Sent from my Nexus 4 using XDA Premium 4 mobile app
The Following User Says Thank You to demkantor For This Useful Post: [ View ]
11th June 2014, 05:17 AM |#17  
Vivek_Neel's Avatar
XDA: ASSIST
Recognized Contributor / Themer
Flag Bangalore
Thanks Meter: 24,319
 
Donate to Me
More
Quote:
Originally Posted by thecoolster

Sorry I didn't understand anything.... I just swapped the cm 11 meta inf file with the original meta inf file.....

@demkantor has guided you very well.
U should take advantage of it.

I repeat once again.
get the update-binary from any other ROM specifically made for your device.
Then modify the existing updater-script.
Make sure Mount points are correct.

That's it.

USE NOTEPAD++ else surely if you would get status error.

Good luck

Sent from my Nexus 5 using XDA Free mobile app
Last edited by Vivek_Neel; 11th June 2014 at 05:23 AM.
The Following 2 Users Say Thank You to Vivek_Neel For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes