Default [Q] Urgent help needed. Fastboot usb not working

I was running resurrection remix, when i saw the 4.4.3 based slimkat. So naturally, i had the urge of flashing it. i was on TWRP 2.7.0.0, i flashed the 2.7.1.0 version of twrp, flashed the rom, gapps, and rebooted, but my phone wont boot up. later, after a series of flashes and wipes, when i failed to boot the rom, i tried to install some other rom. but my phone wont connect to pc in recovery. i flashed the TWRP 2.7.0.0, then CWM 6 but no luck. finally, i flashed phillz along with the kernel from viperx and the phone mounted. copied viperx, flashed, rebooted. now the phone wont pick up my sim card. i thought this might be the issue with the kernel. went back to fastboot to flash the kernel, everything was working fine but as soon as i connected the usb cable, and phone was in fastboot usb mode, my volume buttons and power key stopped working,windows said that a device has malfunctioned, tried to flash but it would just say <waiting for device> and as soon as i removed the usb cable, my phones hardware keys started working again. if booted in hboot with usb connected, it would get stuck on checking sd card for update. Now i am stuck and need urgent help, coz i might miss some important calls if this continues and i am unable to flash.

Some other information that might be useful.
Rom: ViperX
Windows: 7 ultimate.
only HTC usb drivers installed, nothing else.
To flash i usually use Hasoon`s tool as it is very handy
Quote:
1. Nokia 1100 (first phone-originally belonged to mom): retired
2. Nokia 2690: Retired (fell in water.. :P)
3. Samsung Galaxy Y GT-S5360: USB port burned... Still on Duty
4. Samsung Galaxy S2 GT-I9100: SOLD
5. HTC ONE X: Current Phone