Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] (SOLVED) really messed up guys please help a newb T-Mobile HTC One M7

OP Cusade

12th June 2014, 05:17 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2010
More
Decided to flash ViperOne_6.2.0 today and I really messed up somewhere along the way loosing everything on the \sdcard including recoveries and far worse, any ability to issue commands to try and fix it.

Everything was going smoothly until the point when I saw the following; "viperone v6.2.0 install failed. installer status: 7"
I goggled the error and the solution was to update TWRP and try again. Sounded easy enough; I went to work... then something went horribly wrong.

The last successful command I sent my phone was the following;
adb reboot recovery
< waiting for device >
...(bootloader) This project does not support SD card
OKAY [ 0.001s]
finished. total time: 0.001s
fastboot flash recovery twrptmo.img
sending 'recovery' (8608 KB)...
OKAY [ 1.179s]
writing 'recovery'...
OKAY [ 0.635s]
finished. total time: 1.814s
adb push "C:\Users\Fabi\Desktop\ViperOne_6.2.0.zip" "\sdcard\ViperOne_6.2.0.zip"
error: device not found

I have no idea where I went wrong or what the heck happened.

My phone's completely unable or somehow unwilling to mount anything - I'm left without an OS just the ability to recover into the updated TWRP v.2.6.3.0
You're probably thinking that doesn't sound too bad, right? Well, the real issue is that It doesn't let me do anything as it seemingly can't successfully mount anything, no matter what I try.

I've even tried ADB Sideload and HTC Dumlock as other threads suggested but they both just leave endless logs of;
Unable to mount '/data'
Unable to mount '/cache'
Unable to mount internal storage
Unable to mount anything ever again
etc.

Another dilemma, from my computer when the One is in USB Fastboot mode I can't get it to receive anything to try and fix it because it can't find the device.

adb push "C:\Users\mysecretname\Desktop\ViperOne_6.2.0. zip" "\sdcard\ViperOne_6.2.0.zip"
error: device not found

This is way beyond me, I could really use help here.
Last edited by Cusade; 12th June 2014 at 08:23 AM.
12th June 2014, 06:09 AM   |  #2  
alray's Avatar
Senior Member
Flag Montreal, Quebec
Thanks Meter: 1,396
 
3,604 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by Cusade

fastboot flash recovery twrptmo.img

What is this version of twrp?? You should use openrecovery-twrp-2.6.3.3-m7.img or higher version. never seen that ''tmo'' variant of twrp for the m7...

Quote:

adb push "C:\Users\Fabi\Desktop\ViperOne_6.2.0.zip" "\sdcard\ViperOne_6.2.0.zip"
error: device not found

is your phone booted in twrp when doing adb push?

Quote:

My phone's completely unable or somehow unwilling to mount anything - I'm left without an OS just the ability to recover into the updated TWRP v.2.6.3.0

TWRP 2.6.3.0 is far from being an ''updated'' version. Most up to date version for the M7 is 2.7.1.1 and we always recommend using at least version 2.6.3.3.

Quote:

You're probably thinking that doesn't sound too bad, right? Well, the real issue is that It doesn't let me do anything as it seemingly can't successfully mount anything, no matter what I try.

Right

Quote:

I've even tried ADB Sideload and HTC Dumlock as other threads suggested but they both just leave endless logs of;
Unable to mount '/data'
Unable to mount '/cache'
Unable to mount internal storage
Unable to mount anything ever again
etc.

You don't need to mount anything to use adb push. However, you might have corrupted your partitions...

Quote:

Another dilemma, from my computer when the One is in USB Fastboot mode I can't get it to receive anything to try and fix it because it can't find the device.
adb push "C:\Users\mysecretname\Desktop\ViperOne_6.2.0. zip" "\sdcard\ViperOne_6.2.0.zip"
error: device not found

ADB commands only work from a booted OS or from custom recovery, will not work in bootloader.


flash latest twrp recovery for the m7, or at least, TWRP 2.6.3.3:
Code:
fastboot flash recovery openrecovery-twrp-2.6.3.3-m7.img
fastboot erase cache
fastboot reboot-bootloader
then boot the phone in twrp main menu

Code:
adb push your_rom.zip /sdcard/
wait for the file to transfer, there is no progress bar (around 5 min)

then install from twrp.
The Following User Says Thank You to alray For This Useful Post: [ View ]
12th June 2014, 07:32 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by alray

What is this version of twrp?? You should use openrecovery-twrp-2.6.3.3-m7.img or higher version. never seen that ''tmo'' variant of twrp for the m7...

You know.. I can't even remember how I got that version. Anyway, I did as you instructed and it worked out
Thank you man, for awhile I was convinced I had turned my friend into an expensive paperweight. God bless.
12th June 2014, 08:18 AM   |  #4  
alray's Avatar
Senior Member
Flag Montreal, Quebec
Thanks Meter: 1,396
 
3,604 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by Cusade

You know.. I can't even remember how I got that version. Anyway, I did as you instructed and it worked out
Thank you man, for awhile I was convinced I had turned my friend into an expensive paperweight. God bless.

np, could you please edit your thread title to: [Solved] I really messed up guys please help a newb T-Mobile HTC One M7
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes