Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,619 Members 46,272 Now Online
XDA Developers Android and Mobile Development Forum

[Q] CM11 Whisper Push

Tip us?
 
mtdew2kx
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 15
Join Date: Jun 2007

 
DONATE TO ME
Cloud Search [Q] CM11 Whisper Push

I have searched everywhere, and have not found the answer to my specific question. Many similar threads and things I have tried but so far nothing has solved this. I will be as specific as possible and VERY thankful to anyone that can help solve this issue.

I have CM11 and so does my buddy. We are both registered for WhisperPush. I can send him a text and he receives it just fine. When he sends me a text, I receive a notification that states, "Received badly encrypted message, or message encrypted for non-existing session." We have both unregistered and re-registered. We have both deleted the full threads. We have both updated to the latest nightly. I have an i747 on T-Mobile and he has the sprint galaxy S3.

I have noticed that his identity key does not match up on my phone and I seem to have no way to change that. What is strange is when my key changed and I text my brother, he said he was prompted to accept the new one. This isn't happening with my buddy.

Any idea? Thanks in advance.
 
phoenixzzz
Old
#2  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Jun 2014
I had the same problem for ages. It was resolved by both of us:
  1. unregistering our whisperpush accounts
  2. clearing data from the whisperpush app (you should probably backup with titanium first)
  3. re-registering our whisperpush accounts
  4. (if necessary) potentially waiting a day for registrations to propagate

Note that this will mean you lose your old whisperpush key so it could potentially cause a repeat of the same issue, but with another contact. Check your other whisperpush-enabled contacts afterwards to ensure it's working with them. I had to re-register again before mine fully resolved and started working with everyone.

HTH!
The Following User Says Thank You to phoenixzzz For This Useful Post: [ Click to Expand ]
 
mtdew2kx
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 15
Join Date: Jun 2007

 
DONATE TO ME
Thanks for the reply, I will try it out today and post the results in case anyone else has this issue.

Quote:
Originally Posted by phoenixzzz View Post
I had the same problem for ages. It was resolved by both of us:
  1. unregistering our whisperpush accounts
  2. clearing data from the whisperpush app (you should probably backup with titanium first)
  3. re-registering our whisperpush accounts
  4. (if necessary) potentially waiting a day for registrations to propagate

Note that this will mean you lose your old whisperpush key so it could potentially cause a repeat of the same issue, but with another contact. Check your other whisperpush-enabled contacts afterwards to ensure it's working with them. I had to re-register again before mine fully resolved and started working with everyone.

HTH!
 
mtdew2kx
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 15
Join Date: Jun 2007

 
DONATE TO ME
Worked perfect, thank you. Even though I was the one getting the error and had the mismatched ID's, it was the sprint galaxy s3.

1. Unregistered WhisperPush on the sprint GS3
2. Made a backup of WhisperPush using Titanium Backup on the Sprint GS3
3. Wiped data of WhisperPush on GS3 using Titanium Backup
4. Re-registered whisperpush on the Sprint GS3
5. Had him send me a text message and my phone then asked me to accept new encrypted text.

Thank you so much, made it very easy.

Quote:
Originally Posted by phoenixzzz View Post
I had the same problem for ages. It was resolved by both of us:
  1. unregistering our whisperpush accounts
  2. clearing data from the whisperpush app (you should probably backup with titanium first)
  3. re-registering our whisperpush accounts
  4. (if necessary) potentially waiting a day for registrations to propagate

Note that this will mean you lose your old whisperpush key so it could potentially cause a repeat of the same issue, but with another contact. Check your other whisperpush-enabled contacts afterwards to ensure it's working with them. I had to re-register again before mine fully resolved and started working with everyone.

HTH!
Tags
cm11, encryption., whisperpush
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes