Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,495 Members 37,154 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Razr xt890i

Tip us?
 
asgaard76
Old
(Last edited by asgaard76; 10th June 2014 at 10:05 AM.)
#21  
Junior Member - OP
Thanks Meter 0
Posts: 10
Join Date: May 2014
Location: Kildare/Podkowa Lesna
Ok. guys quick update.
Friend of mine who fix phones put hands on that Motorola and tried everything. As he said there is a little chance to fix it, but first of all You need to get to memory without unlocked bootloader, as it's blocked all commands. Any suggestions? I think he means memory chip must be reprogrammed, but bootloader is locked and don't take any commands.
 
grim84
Old
(Last edited by grim84; 13th June 2014 at 05:54 PM.)
#22  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Quote:
Originally Posted by Hazou View Post
It could be indeed an emmc problem, in that case a repair at motorola can only fix it, or u will need to replace the motherboard, that will set u back another 150 dollars.

But, u successfully flashed the logo, so a part of the emmc is still working correctly i assume. btw, my knowledge about emmc problems stops here..

The next steps i should take is the following, we will reformat/partition your device, as far as it goes. But I never done this, didn't need to i only know it is possible. Everything that happens now is on your own responsibility!!

1. Download your correct firmware, must be jellybean 4.1.2 from here(firmware)
2. Extract it content in a folder like "STOCKROM"
3. Download new fastboot files from here (mfastboot,xda)
4. Extract the new mfastboot files in the folder "STOCKROM" if u named it like that.
5. Connect your device with your pc, make sure all drivers are correctly installed, and boot in fastboot mode (power + volume down)
6. Flash each of the partitions in sequence using mfastboot (is like fastboot, but can install files larger then 100mb), you need to enter the following commands one-by-one checking that each one returns an [OKAY]. If it doesnt work, i am out of ideas. sry, but report anyway what happend
7.
Code:
mfastboot flash gpt gpt_signed
mfastboot flash motoboot motoboot
mfastboot flash boot boot_signed
mfastboot flash recovery recovery_signed
mfastboot flash motobp motobp
mfastboot flash system system_signed
mfastboot flash cdrom cdrom_signed
mfastboot erase cache 
mfastboot erase userdata 
mfastboot reboot
Good luck with it, i will hear from you.

Hazou

btw, erasing 'data' is impossible, fastboot doesn't know 'data', only 'userdata'
Hello Hazou! I'm having a similar problem (my thread is at http://forum.xda-developers.com/show....php?t=2780897 ), I tried using mfastboot and everything goes well until the system part... is there anything I could do? Thanks


C:\razr>mfastboot flash gpt gpt_signed
(bootloader) Variable not supported!
target max-download-size: 100MB
sending 'gpt' (32 KB)...
OKAY [ 0.381s]
writing 'gpt'...
(bootloader) Flashing primary GPT image...

(bootloader) Flashing backup GPT image...

OKAY [ 1.973s]
finished. total time: 2.360s

C:\razr>mfastboot flash motoboot motoboot
(bootloader) Variable not supported!
target max-download-size: 100MB
sending 'motoboot' (23273 KB)...
OKAY [ 2.471s]
writing 'motoboot'...
(bootloader) flashing image dnx...

(bootloader) flashing image ifwi...

(bootloader) flashing image bos...

(bootloader) flashing image logo...

(bootloader) flashing image ulogo...

OKAY [ 2.040s]
finished. total time: 4.517s

C:\razr>mfastboot flash boot boot_signed
(bootloader) Variable not supported!
target max-download-size: 100MB
sending 'boot' (11264 KB)...
OKAY [ 1.300s]
writing 'boot'...
OKAY [ 1.292s]
finished. total time: 2.598s

C:\razr>mfastboot flash recovery recovery_signed
(bootloader) Variable not supported!
target max-download-size: 100MB
sending 'recovery' (11264 KB)...
OKAY [ 1.268s]
writing 'recovery'...
OKAY [ 1.316s]
finished. total time: 2.590s

C:\razr>mfastboot flash motobp motobp
(bootloader) Variable not supported!
target max-download-size: 100MB
sending 'motobp' (17091 KB)...
OKAY [ 1.943s]
writing 'motobp'...
OKAY [ 73.637s]
finished. total time: 75.585s

C:\razr>mfastboot flash system system_signed
(bootloader) Variable not supported!
target max-download-size: 100MB
Multi-Flash is enabled!
sending 'system' (102400 KB)...
OKAY [ 9.675s]
writing 'system'...
OKAY [ 0.416s]
sending 'system' (102400 KB)...
(bootloader) BLKDISCARD ioctl /dev/block/mmcblk0 fail
OKAY [ 11.208s]
writing 'system'...
FAILED (remote failure)
finished. total time: 21.590s

C:\razr>
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Flyme OS Finds Its Way to the Google Nexus 5

Flyme OS is a heavily modified Android variantdeveloped by the Meizu team for their MX … more

MultiROM Makes Its Way to the LG G2

Over the last few weeks, we’ve seen quite a fewflagship (and former flagship) devicesget to … more

Jair Player with a Major Update–Here’s What’s New!

Back in May, we talked a bit aboutJair Player, a nice looking music … more