Thread Closed

[Q] Moto X Display Languages

13th June 2014, 06:22 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Hi All,

Essentially, I had bought the Moto X T-Mobile & Unlocked sim-cards as a gift for my wife. Unfortunately, I found that the Moto X T-mobile comes with only 4 languages installed. So, Arabic is not one of them for system display language. My wife doesn't speak English and she only speaks Arabic. I would really appreciate if you can help us to add more languages to the phone without rooting the phone?

The UK Android version has Arabic, How can we get UK version install to the phone.

Thanks
13th June 2014, 06:38 AM   |  #2  
KJ's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 3,687
 
8,862 posts
Join Date:Joined: May 2011
More
Hi there!

I'm afraid the only way to add languages to the system would be by unlocking bootloader (which voids your warranty) then rooting and installing a custom ROM that has support for Arabic....if any do.

You can browse the dev section found in the moto x section, here...

http://forum.xda-developers.com/moto...03952672425658

See if any ROMs in the dev section list Arabic as a language. Or you can post your question in the Q&A section.

But unless you root.....there's no way to do it. And the custom ROM would need to support the language as well.

Good luck! 😊
The Following User Says Thank You to KJ For This Useful Post: [ View ]
13th June 2014, 06:53 PM   |  #3  
KJ's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 3,687
 
8,862 posts
Join Date:Joined: May 2011
More
You should have no issue flashing the UK firmware....so long as the firmware is for the same model.... As in xt10xx model number.

If you do encounter issues....you can always flash the same firmware you are on now again. So be sure what you have now.

Here is a thread to help with that...

http://forum.xda-developers.com/show....php?t=2446515

Also note: very important.....if you ate on 4.4.2 or 4.4.3, DO NOT downgrade lower than 4.4.2....you could brick your device. Just keep that in mind now and in the future.
Last edited by KJ; 13th June 2014 at 06:57 PM.
The Following User Says Thank You to KJ For This Useful Post: [ View ]
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes