Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,985 Members 41,283 Now Online
XDA Developers Android and Mobile Development Forum

Very flaky and unreliable wifi connection on my Z2 !!

Tip us?
 
s_superman
Old
#1  
s_superman's Avatar
Senior Member - OP
Thanks Meter 118
Posts: 463
Join Date: Jan 2011
Location: Cairo
Default Very flaky and unreliable wifi connection on my Z2 !!

I've owned the Xperia Z2 for almost ten days now, and I've never managed to hold a wifi connection for more that two minutes, after that wifi stays connected normally but no internet connection !!
the only solution is to reboot and the wifi will work again for a minute or two and then does it all over again !!
I've tried all possible solutions like soft-reset and switching off my wifi and even re-installing the firmware for Sony PC companion and nothing !!

is anyone else having the same issues??
Own right now :

Xperia Z2 D6503

ROM :Stock 17.1.1.A.0.402
Kernel : Stock locked


One M7C Dual SIM 802w

ROM :Stock Sense 6.0 KitKat + Xposed
Kernel : Stock
HBOOT : Rumrunner S-OFF

Google NEXUS 4

ROM : Rooted Paranoid Android
Kernel : Franco + bponury TouchControl

Owned before :
HD2(Retired) EVO 3D (Dodgy screen\retired) Desire 600 Dual SIM (Sold - poor development) HTC One(Sold - Not enough memory)


If I helped you, dont forget to press Thanks
 
Aarseth
Old
#2  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2013
Quote:
Originally Posted by s_superman View Post
I've owned the Xperia Z2 for almost ten days now, and I've never managed to hold a wifi connection for more that two minutes, after that wifi stays connected normally but no internet connection !!
the only solution is to reboot and the wifi will work again for a minute or two and then does it all over again !!
I've tried all possible solutions like soft-reset and switching off my wifi and even re-installing the firmware for Sony PC companion and nothing !!

is anyone else having the same issues??
I am :\

Bought the phone yesterday. Already used it a lot and loving it. But this morning I'm at home and I see WiFi issues. Sometimes the internet just doesn't work anymore (although I'm still conected and my other devices work fine). And I also got stuck to "obtaining IP address..."

I really hope it's not a hardware fault and that an update is coming (I did all the Sony updates yesterday). But you say it's been 10 days it is that way ??


On an unrelated note, each time I boot it, an alert tells me to put the caches back on to remain waterproof. Does that mean it detect the caches are removed ?because they aren't!
 
BanziBaby
Old
#3  
BanziBaby's Avatar
Senior Member
Thanks Meter 65
Posts: 292
Join Date: Oct 2010
No issues with wifi here, as for the make sure flaps are closed message that will appear every time you reboot the phone, just tick don't show this again & it will stop appearing. It's just a general warning to make sure the flaps are closed.
 
s_superman
Old
#4  
s_superman's Avatar
Senior Member - OP
Thanks Meter 118
Posts: 463
Join Date: Jan 2011
Location: Cairo
The weird thing is that I have both.my HTC and nexus in the same room connected to.the same wifi access point and they are working properly.... This is very bad

Sent from my D6503 using XDA Free mobile app
Own right now :

Xperia Z2 D6503

ROM :Stock 17.1.1.A.0.402
Kernel : Stock locked


One M7C Dual SIM 802w

ROM :Stock Sense 6.0 KitKat + Xposed
Kernel : Stock
HBOOT : Rumrunner S-OFF

Google NEXUS 4

ROM : Rooted Paranoid Android
Kernel : Franco + bponury TouchControl

Owned before :
HD2(Retired) EVO 3D (Dodgy screen\retired) Desire 600 Dual SIM (Sold - poor development) HTC One(Sold - Not enough memory)


If I helped you, dont forget to press Thanks
 
kotton666
Old
#5  
Senior Member
Thanks Meter 17
Posts: 233
Join Date: Jul 2010
My wifi is **** as well. It makes streaming video and music impossible as it keeps dropping out. Is there a fix for rooted devices?

Sent from my D6503 using XDA Free mobile app
 
s_superman
Old
#6  
s_superman's Avatar
Senior Member - OP
Thanks Meter 118
Posts: 463
Join Date: Jan 2011
Location: Cairo
this is really getting very annoying !!
I've finished my one month mobile data package in just twelve days because of this !!
I'm starting to regret switching from reliable HTC phones to Sony
what the hell is causing this !
Own right now :

Xperia Z2 D6503

ROM :Stock 17.1.1.A.0.402
Kernel : Stock locked


One M7C Dual SIM 802w

ROM :Stock Sense 6.0 KitKat + Xposed
Kernel : Stock
HBOOT : Rumrunner S-OFF

Google NEXUS 4

ROM : Rooted Paranoid Android
Kernel : Franco + bponury TouchControl

Owned before :
HD2(Retired) EVO 3D (Dodgy screen\retired) Desire 600 Dual SIM (Sold - poor development) HTC One(Sold - Not enough memory)


If I helped you, dont forget to press Thanks
 
BanziBaby
Old
#7  
BanziBaby's Avatar
Senior Member
Thanks Meter 65
Posts: 292
Join Date: Oct 2010
Check in wifi settings & tap the 3 button menu then tap advanced & make sure Avoid Poor Connections is unticked, I also always set the keep wifi on during sleep to always & never have any issues.
 
Aarseth
Old
#8  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2013
If that can help, I think the issue is gone with my z2. What I did : backed up my whole phone using the Sony app, factory reset the phone and restore the backup (strangely, some apps weren't restored so if you can use titanium, it may be better). I also did what BanziBaby just said. No problem until now, crossing the fingers

Envoyé de mon D6503 en utilisant Tapatalk
 
abd_alazeez2002
Old
#9  
abd_alazeez2002's Avatar
Senior Member
Thanks Meter 51
Posts: 245
Join Date: Sep 2010
Or fine with me.
Try playing with the ip like use a static ip.

Sent from my D6503 using XDA Free mobile app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...