Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,778 Members 52,030 Now Online
XDA Developers Android and Mobile Development Forum

Camera not working on .402

Tip us?
 
whiteblazer01
Old
#1  
whiteblazer01's Avatar
Senior Member - OP
Thanks Meter 3
Posts: 180
Join Date: Feb 2007
Default Camera not working on .402

I updated to the new firmware today (via notification), and now my camera doesn't work at all. Snapchat also crashes when trying to use the camera (so not necessarily the camera app).

In the camera app, a half-press on the camera button is recognized, but there is no focus beep, and tapping on the screen doesn't focus. When I try to take a picture, the app freezes.

Is there any fix, or possibly to revert back to the previous firmware?
 
Envious_Data
Old
#2  
Envious_Data's Avatar
Senior Member
Thanks Meter 667
Posts: 1,625
Join Date: Oct 2012
Location: Yaizu
Android 4.4.2 is very buggy and not very stable, it seems a factory reset or even a device repair through sony PC companion should do the job

Sent from my D6503 using XDA Premium 4 mobile app
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
 
whiteblazer01
Old
#3  
whiteblazer01's Avatar
Senior Member - OP
Thanks Meter 3
Posts: 180
Join Date: Feb 2007
Thanks for the info. I haven't had any previous problems with the phone, this is the first time. I'll try a repair and see if that solves the problem (if not, then factory reset).
 
Envious_Data
Old
#4  
Envious_Data's Avatar
Senior Member
Thanks Meter 667
Posts: 1,625
Join Date: Oct 2012
Location: Yaizu
Quote:
Originally Posted by whiteblazer01 View Post
Thanks for the info. I haven't had any previous problems with the phone, this is the first time. I'll try a repair and see if that solves the problem (if not, then factory reset).
Yah, it should be fixed in the next upcoming update or the next majour since these bugs are android bugs and not sony caused

Sent from my D6503 using XDA Premium 4 mobile app
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes