Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,143 Members 52,286 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nova Launcher: No home button animations

Tip us?
 
Te Kaihau
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Jul 2012
Location: Southampton
Default [Q] Nova Launcher: No home button animations

Hey everyone. I just got a M8, like today, and I'm loving it. I've been happily getting all my apps and everything sorted, but I've hit a bit of a problem with Nova Launcher. It's installed, set as default, I've ported across the settings from my old phone (HTC One X, Sense 5, 4.2.2) and everything looks good, except..... For some reason, when I hit the home button I get no animations. Just a little bit of lag and then the screen just switches to default. The Sense 6 launcher, however, does the nice scrolling thing back to my home page, which I want, but Nova doesn't.

I've hit google, found nothing. Tried all the settings I can think of and nothing jumps out at me (the App Animation setting seemed the obvious, but that didn't seem to help). So, has anybody else had this problem? Am I missing something incredibly obvious? Or is this just the way it is with the M8 and the current version of Nova? It's not enough to really annoy me, but the lack of animation is a bit jarring.

Thanks!
 
jaythenut
Old
#2  
jaythenut's Avatar
Senior Member
Thanks Meter 1474
Posts: 5,075
Join Date: Sep 2012
Quote:
Originally Posted by Te Kaihau View Post
Hey everyone. I just got a M8, like today, and I'm loving it. I've been happily getting all my apps and everything sorted, but I've hit a bit of a problem with Nova Launcher. It's installed, set as default, I've ported across the settings from my old phone (HTC One X, Sense 5, 4.2.2) and everything looks good, except..... For some reason, when I hit the home button I get no animations. Just a little bit of lag and then the screen just switches to default. The Sense 6 launcher, however, does the nice scrolling thing back to my home page, which I want, but Nova doesn't.

I've hit google, found nothing. Tried all the settings I can think of and nothing jumps out at me (the App Animation setting seemed the obvious, but that didn't seem to help). So, has anybody else had this problem? Am I missing something incredibly obvious? Or is this just the way it is with the M8 and the current version of Nova? It's not enough to really annoy me, but the lack of animation is a bit jarring.

Thanks!
try nova beta http://novalauncher.com/beta/
 
Matt
Old
#3  
Matt's Avatar
Senior Member
Thanks Meter 1199
Posts: 1,845
Join Date: Feb 2012
Location: Nottingham, UK

 
DONATE TO ME
Quote:
Originally Posted by Te Kaihau View Post
Hey everyone. I just got a M8, like today, and I'm loving it. I've been happily getting all my apps and everything sorted, but I've hit a bit of a problem with Nova Launcher. It's installed, set as default, I've ported across the settings from my old phone (HTC One X, Sense 5, 4.2.2) and everything looks good, except..... For some reason, when I hit the home button I get no animations. Just a little bit of lag and then the screen just switches to default. The Sense 6 launcher, however, does the nice scrolling thing back to my home page, which I want, but Nova doesn't.

I've hit google, found nothing. Tried all the settings I can think of and nothing jumps out at me (the App Animation setting seemed the obvious, but that didn't seem to help). So, has anybody else had this problem? Am I missing something incredibly obvious? Or is this just the way it is with the M8 and the current version of Nova? It's not enough to really annoy me, but the lack of animation is a bit jarring.

Thanks!
If you go to App Animation and set it to Jellybean, this works for me
Devices: HTC One M8, iPhone 5s
 
Te Kaihau
Old
#4  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Jul 2012
Location: Southampton
Quote:
try nova beta http://novalauncher.com/beta/
Thanks, but the changelog on the site suggests I'm using the latest version of Nova anyway..

Quote:
If you go to App Animation and set it to Jellybean, this works for me
Tried that, but does nothing

It really is weird, especially when I can't find ~anybody~ having the same problem on this device. It's almost like Nova freezes up slightly when it would normally be running the animation, as if it's conflicting with Sense 6 or some way the home button is rigged up.

Bizarre.

Right now, my options are either live with it (it isn't that annoying after all, it just bugs me) or go back to Sense (which runs lovely, but i can't get on with the vertically scrolling app drawer).
 
nycebo
Old
#5  
Member
Thanks Meter 6
Posts: 81
Join Date: Sep 2010
Location: New York, NY
Quote:
Originally Posted by Te Kaihau View Post
Right now, my options are either live with it (it isn't that annoying after all, it just bugs me) or go back to Sense (which runs lovely, but i can't get on with the vertically scrolling app drawer).
Are you on Sense or GPE or another ROM?

I use Nova and leave the app animation on system default. The animation works just fine (not to say that you don't have an issue but just to let you know that it should work). Do you have animations on your stock launcher (sense/google now launcher)? If not, then perhaps there is an issue with your device that may require a reset and reinstall?
The Following User Says Thank You to nycebo For This Useful Post: [ Click to Expand ]
 
Te Kaihau
Old
#6  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Jul 2012
Location: Southampton
Quote:
Originally Posted by nycebo View Post
Are you on Sense or GPE or another ROM?

I use Nova and leave the app animation on system default. The animation works just fine (not to say that you don't have an issue but just to let you know that it should work). Do you have animations on your stock launcher (sense/google now launcher)? If not, then perhaps there is an issue with your device that may require a reset and reinstall?
Thanks for your reply.

I'm on Sense, completely stock. Nova was one of the first things to go on when I got the phone too. To be honest, I've just been using the Sense launcher in the last week and I'm getting used to it. Not as nice as nova, but pretty smooth and simple. Now, there are other things about KitKat that are annoying me even more. Really starting to consider rooting, althoughI've never done it before and I'm a little nervous. Maybe I should practice on my One X?
 
Te Kaihau
Old
#7  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Jul 2012
Location: Southampton
Quote:
Originally Posted by nycebo View Post
Are you on Sense or GPE or another ROM?

I use Nova and leave the app animation on system default. The animation works just fine (not to say that you don't have an issue but just to let you know that it should work). Do you have animations on your stock launcher (sense/google now launcher)? If not, then perhaps there is an issue with your device that may require a reset and reinstall?
Um. Okay. I just switched to Nova and now the animations are working..... No idea what I did. Only thing I can think of is maybe turning off fastboot last night before a reset, although I'm sure I tried that last weekend......



Whatever. Happy now 😊

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Xperia Z1 Stereo Speaker Mod, Cell Phone Unlocking Legal Again! – XDA Developer TV

Cell Phone Unlocking is legal again!! That and much … more

[OTA Captured] Verizon LG G Pad 8.3 Finally Gets Official KitKat Update

It’s been almost nine months since the LG G Pad … more

Enjoy Wallpaper Overload with PhotoPhase

We don’t usually feature live wallpapers on the XDA Portal unless they are somewhat innovative … more

Monitor What Your Phone’s Camera Sees with Android Wear

Having a smart device strapped to your wrist certainly has its merits. A … more