Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,098 Members 46,404 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Shotty touchscreen responsiveness (Lately been working when it wants to) HELP!

Tip us?
 
zmag
Old
#1  
zmag's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 309
Join Date: Jan 2011
Unhappy [Q] Shotty touchscreen responsiveness (Lately been working when it wants to) HELP!

Hey XDA,

The past 3 days, my touchscreen is seeming to get stuck in certain spots (to the point where I cannot slide screen left/right or up/down)

Also, the soft keys (Back, Home & Recent Apps) become unresponsive also.

I've tried cleaning the screen multiple times (mostly with lens cleaner) I even tried Windex - but it only works when it wants to.

I went to Settings - Developer Options - Show Touches... just to see where the screen is getting held up, and sometimes it shows a white dot where it seems to get stuck, and cleaning the screen only helps 25% of the time.

I have _never_ had this problem, does anyone have this issue? (or something similar?)

I'm rooted, and if installing the new touchscreen drivers will help lemme know (and provide some links please)

Thanks in advance! - zmag
 
lreyes
Old
#2  
lreyes's Avatar
Senior Member
Thanks Meter 496
Posts: 1,407
Join Date: Jun 2012
Quote:
Originally Posted by zmag View Post
Hey XDA,

The past 3 days, my touchscreen is seeming to get stuck in certain spots (to the point where I cannot slide screen left/right or up/down)

Also, the soft keys (Back, Home & Recent Apps) become unresponsive also.

I've tried cleaning the screen multiple times (mostly with lens cleaner) I even tried Windex - but it only works when it wants to.

I went to Settings - Developer Options - Show Touches... just to see where the screen is getting held up, and sometimes it shows a white dot where it seems to get stuck, and cleaning the screen only helps 25% of the time.

I have _never_ had this problem, does anyone have this issue? (or something similar?)

I'm rooted, and if installing the new touchscreen drivers will help lemme know (and provide some links please)

Thanks in advance! - zmag
seems like a hardware issue..I'd take it to sprint and see what they can do.

Sent from my EVO LTE using Tapatalk

If you need any help,task to be done, contact me via PM.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes