Default Serioux HD TAB S805TAB

Hello everyone!

I'm new arround and I came here hoping to solve some stuff regarding this tablet.
It is sold in Romania under SERIOUX brand:

http://www.serioux.com/products/tabl...hd-tab-s805tab

I have a model with A10 ALLWINER, not ROCKCHIP. They had problems with the chinese manufacturer and decided to build it with rockchip.
I'm stuck at original ROM, I have no CWM, tablet is rooted, default browser is horrible, even with opera or any other browsers... I have this big lag when loadind web pages and this should not be normal... There is no such problem as low wifi signal or any other hardware stuff, no, it is just imossible to surf the web...
It has Android 4.0.4.
I made a request to this vendor, importer, SERIOUX, for another firmware but they only provided me the stock rom last year... which I already mention it, it is HORRIBLE!!! I never heard from them since then so I'm stuck with this rubbish stock ROM.
Tried to find a simmilar product on the web, I even made some attempts to install some ROMs but without a succes... either camera not working, or touch or wifi and so on... I don't know what to do.

Don't want to buy another product because the tablet belong to my daughter and is in the learning process so... I am gonna still hold on to it, but I need some help getting it better!!!

The site which sell a tablet simmilar to mine is KOCASO from USA... tried their ROM but no luck.
I even sent them an email but no answer from them more than six months or so...

http://www.kocaso.com/product_M870.html

Thank you in advance for anyone who can lend a hand in this matter!

Cheers,
Attached Thumbnails
Click image for larger version

Name:	Specification.jpg
Views:	12
Size:	226.1 KB
ID:	2799609  
Attached Files
File Type: zip buildprop.zip - [Click for QR Code] (1.5 KB, 1 views)