Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,628 Members 38,913 Now Online
XDA Developers Android and Mobile Development Forum

VanirAOSP 4.4.3 on Samsung Galaxy XCover2 GT-S7710 - Fix "Cannot connect to camera"

Tip us?
 
rkrell
Old
(Last edited by rkrell; 13th June 2014 at 08:01 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Lightbulb VanirAOSP 4.4.3 on Samsung Galaxy XCover2 GT-S7710 - Fix "Cannot connect to camera"

I just want to share how to fix camera issues on XCover 2 after flashing to VanirAOSP 4.4.3. I hit a problem already reported multiple times: Launching of any camera like the Google Camera fails reporting "Cannot connect to camera", regardless if you install the camera with the Gapps package or from store.

After some investigation, I got my camera finally work:
- Uninstalled Google Camera from store
- flashed to latest Vanir 4.4.3.061114
- Installed Android Terminal Emulator (Jack Palevich) from store, doesn't rely on BusyBox
- Open Android Terminal Emulator and launch:
su -
mount -o rw,remount /system
ln -s /system/lib/libjhead.so /system/lib/libhead.so
mount -o ro,remount /system

- Reboot phone
- Installed Google Camera from store

I used SuperSU as root application.
Thanks to all of you guys participating in several discussions for help on this.

I'd like to have this in the VanirOS image. But I'm still disabled to reply to more specific threads.
 
thedicemaster
Old
#2  
Senior Member
Thanks Meter 268
Posts: 781
Join Date: May 2009
wrong device.
this section is for the samsung galaxy camera, not for samsung devices that happen to have a camera.
THREAD CLOSED
Subscribe
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes