Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Dialer FC After CM11 4.4.3 Nightly Flash

OP TheBarkeep

7th June 2014, 07:36 PM   |  #1  
OP Junior Member
Thanks Meter: 2
 
4 posts
Join Date:Joined: Jan 2014
More
My issue concerns SPH-L710 GS3 on Sprint. I've successfully been running CM11 nightlies since November with no major issues.
After installing the latest June 6th d2lte nightly, a new 4.4.3 build, the dialer continues to force close. Wiped cache and factoried with Philz, and installed the new 4.4.3 build, and dialer worked fine. Then I did a simple Nandroid restore of most user apps &data, excluding the restore of the dialer and system apps from the 4.4.2 build, so there wouldn't be any conflicts. Using Holo theme. The dialer still FCs, and I can't see any user apps that would be causing an issue. Any ideas on how to resolve the issue?
Last edited by TheBarkeep; 7th June 2014 at 09:36 PM.
8th June 2014, 06:08 AM   |  #2  
roirraW "edor" ehT's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 1,779
 
3,402 posts
Join Date:Joined: May 2010
More
In cases like that, to be completely sure it's not a user app conflict, what I've done is break my user app restore into halves.

So I restore one half of the apps I want to, say maybe ones starting with A to M. If the problem doesn't occur try restoring half of the other half (a quarter), say N to T, etc, gradually narrowing down the offending app.

Once you restore a selection of apps and the problem occurs, then you'd have to restore a nandroid from before restoring any apps, then restore half of the apps that you did the last time. Just keep going and eventually you'll find the culprit. It might even make sense once you see which app is causing the problem.

Of course, another possibility is that the nightly is what has the conflict and that a newer nightly will fix it.

Sent from my Sprint Samsung Galaxy SIII on TouchWiz 4.4.2 with Wicked X v6.5, Ktoonsez' latest kernel and the latest Philz Touch Recovery.
The Following User Says Thank You to roirraW "edor" ehT For This Useful Post: [ View ]
9th June 2014, 11:40 PM   |  #3  
Member
Thanks Meter: 15
 
88 posts
Join Date:Joined: Sep 2011
More
In my case it was the theme. Revert to default cm11 theme and it should work.
The Following 2 Users Say Thank You to aouni_tahech For This Useful Post: [ View ]
16th June 2014, 10:04 PM   |  #4  
OP Junior Member
Thanks Meter: 2
 
4 posts
Join Date:Joined: Jan 2014
More
Thanks for the ideas guys. I did find that although I was positive it wasn't the theme issue, and I was using default Holo, that I had to uninstall all other themes and dialer started working again. The only other issue I have now coincidentally, is a constant FC when opening display settings. Furk, I never had issues with any earlier builds.
The Following User Says Thank You to TheBarkeep For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes