Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLVED] SuperSU binary conflict with Reboot fix in 15.4.A.1.9

OP bananabee

11th June 2014, 07:30 PM   |  #1  
OP Junior Member
Flag Los Baņos, Laguna
Thanks Meter: 2
 
10 posts
Join Date:Joined: Aug 2013
More
I flashed the new 15.4.a.1.9 firmware and tried rooting it with the same method I did with the previous firmware 15.4.a.0.23 (which was working). After applying the reboot fix, I tried to open SuperSU but it displayed a warning "There is no SU binary installed, and SuperSU cannot install it. This is a problem!" But when I reinstalled SuperSU from SD through recovery mode, phone gets stuck at bootloop when rebooting. Tried to take out SD card and it escaped bootloop, but I don't really want to do that every time because Link2SD won't load apps when SD card is taken out at phone startup.

Basically, it's either I have a missing su binary caused by reboot fix, or a problem with bootloop.

Should I just return to the older firmware or there is somehow a way to go around this? Thanks in advance. [emoji4]

Sent from my C1904 using Tapatalk
Last edited by bananabee; 3rd July 2014 at 05:13 PM.
12th June 2014, 01:16 PM   |  #2  
Bonoboo's Avatar
Senior Member
Thanks Meter: 1,025
 
897 posts
Join Date:Joined: Dec 2012
More
Quote:
Originally Posted by bananabee

After applying the reboot fix

Reboot fix not needed on 4.3
Just re-flash firmware, install kernel with recovery and flash SuperSU ZIP.
The Following User Says Thank You to Bonoboo For This Useful Post: [ View ]
17th June 2014, 05:25 AM   |  #3  
Junior Member
Thanks Meter: 0
 
19 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by bananabee

I flashed the new 15.4.a.1.9 firmware and tried rooting it with the same method I did with the previous firmware 15.4.a.0.23 (which was working). After applying the reboot fix, I tried to open SuperSU but it displayed a warning "There is no SU binary installed, and SuperSU cannot install it. This is a problem!" But when I reinstalled SuperSU from SD through recovery mode, phone gets stuck at bootloop when rebooting. Tried to take out SD card and it escaped bootloop, but I don't really want to do that every time because Link2SD won't load apps when SD card is taken out at phone startup.

Basically, it's either I have a missing su binary caused by reboot fix, or a problem with bootloop.

Should I just return to the older firmware or there is somehow a way to go around this? Thanks in advance. [emoji4]

Sent from my C1904 using Tapatalk

I am facing the same problem. Root fixer causes this. I am clueless at the moment. Going to reflash ROM.
17th June 2014, 05:40 AM   |  #4  
OP Junior Member
Flag Los Baņos, Laguna
Thanks Meter: 2
 
10 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by dearbasheer

I am facing the same problem. Root fixer causes this. I am clueless at the moment. Going to reflash ROM.

I have found a way. Upon applying reboot fix, open Link2SD. In Settings, uncheck "relink lib files at boot" and "relink dex files at boot". Then turn off your phone and reinstall SuperSU from SD at recovery mode. Then reboot system. It should boot normally. Mine did. Hope this helps

Sent from my C1904 using Tapatalk
Last edited by bananabee; 17th June 2014 at 06:35 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes