Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,220 Members 44,820 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Random reboots and lock ups (memory leak?)

Tip us?
 
heartspains88
Old
#1  
Senior Member - OP
Thanks Meter 3
Posts: 119
Join Date: Jun 2010
Default [Q] Random reboots and lock ups (memory leak?)

Hey all,

I've had this issue with everything but the stock rom. After a certain amount of time the phone either locks up to where I have to pop the battery, or will graphic glitch on the screen for a second and then auto reboot. Happens maybe 2-4 times a day depending on the day.

I've done a full wipe and full factory reset. I've been modding phones for ages and this is the first time I've encountered this issue. Everything else seems to run completely fine.

I'm running resurrection rom, but it's done this on several other roms I've tried. However all roms are AOKP/AOSP based if that's relevant.

If there is anymore information I can offer please don't hesitate to ask. I searched the forums and couldn't seem to find anyone else really talking about this. It can be a giant headache so hopefully I can get it sorted.
Bl4ckpheniX, "Best thing you can really do is try and ignore it and move on. Try and help someone, or ask for help. That's the point of this forum. Everyone is here to learn how to make their phone better. "
The Following User Says Thank You to heartspains88 For This Useful Post: [ Click to Expand ]
 
jdidtht
Old
#2  
jdidtht's Avatar
Senior Member
Thanks Meter 1116
Posts: 2,039
Join Date: Sep 2012
Location: minneapolis
Quote:
Originally Posted by heartspains88 View Post
Hey all,

I've had this issue with everything but the stock rom. After a certain amount of time the phone either locks up to where I have to pop the battery, or will graphic glitch on the screen for a second and then auto reboot. Happens maybe 2-4 times a day depending on the day.

I've done a full wipe and full factory reset. I've been modding phones for ages and this is the first time I've encountered this issue. Everything else seems to run completely fine.

I'm running resurrection rom, but it's done this on several other roms I've tried. However all roms are AOKP/AOSP based if that's relevant.

If there is anymore information I can offer please don't hesitate to ask. I searched the forums and couldn't seem to find anyone else really talking about this. It can be a giant headache so hopefully I can get it sorted.
If this has just started recently in would say it is indeed apart of the cm base, and related to kernel issue. Since the kernel devs are using cm and their kernel base most ROMs kernels have the same base, which means in a round about way they may react the same way on your device. To me, you said graphic glitch, then reboot. I would bump up your voltage little by little and see if it stops, I also would change govs in the kernel.. I'm assuming it happens on any cm kernels you've tried? Yank555 has an awesome cm kernel I would highly recommend, or even imoseyon always has a solid stable cm kernel as well.

The Following User Says Thank You to jdidtht For This Useful Post: [ Click to Expand ]
 
Frank Westlake
Old
#3  
Frank Westlake's Avatar
Senior Member
Thanks Meter 157
Posts: 432
Join Date: Nov 2013
How are you transferring the firmware? The heavy cable with the heavy plug? If so, it might have damaged your device's USB port and is causing intermittent disconnections which are corrupting the data as it is transferred. Try a lightweight cable and make sure it is firmly seated, then don't let it move during the transfer.

If this solves it then maybe look into replacement due to faulty design.

Frank
The Following User Says Thank You to Frank Westlake For This Useful Post: [ Click to Expand ]
 
heartspains88
Old
#4  
Senior Member - OP
Thanks Meter 3
Posts: 119
Join Date: Jun 2010
It is happening on all roms, however the only custom roms I've tried are CM based. I'll take a look at these other kernels and see if that resolves. Thanks for the help and idea's so far guys.
Bl4ckpheniX, "Best thing you can really do is try and ignore it and move on. Try and help someone, or ask for help. That's the point of this forum. Everyone is here to learn how to make their phone better. "
 
dtr145r
Old
#5  
dtr145r's Avatar
Senior Member
Thanks Meter 270
Posts: 1,245
Join Date: Nov 2010
Location: pennsylvania
I've been having the same issues. Hellish reboots though. 10+ a day... Keep me posted. Thanks

Sent from my SM-N900T using XDA Premium 4 mobile app
.
Mighty Text<--- Try it out! send texts from the computer using our cell number!

Macrodriod Device Automation


Device 1: .: Note 3 T-Mobile :.
Rom: .: Odexed Cyanogen Mod 11 :.
Recovery: .: TWRP 2.7.2.0 :.


Device 2: .: SGS4 T-Mobile :.
Rom:.: Cyanogen Mod 11 :.
Recovery: .: TWRP 2.7.1.0 :.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes