Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Moto G won't turn on :(

OP fab0004

18th June 2014, 08:56 AM   |  #1  
fab0004's Avatar
OP Junior Member
Flag Mumbai
Thanks Meter: 6
 
14 posts
Join Date:Joined: Jan 2011
More
Hey guys, something happened to my Moto G this morning and now it won't turn on. This has happened to me previously as well where the battery drained and charging it sorted the problem out.
But this time the battery was fully charged and now it won't turn on, neither does the screen light up when I connect it to the charger (with the 0% battery logo).
Something to note - I got an update from the play store for Motorola Boot Services. My phone restarted once and showed me the new boot animation (World Cup). Then it just went dead. Not sure if this has to do something with it.
I was running stock with an unlocked bootloader, root and twrp. XT1033 dual SIM.

Any suggestions will be appreciated. Any way to at least get the phone back to stock so I can take it back to Motorola.
Last edited by fab0004; 18th June 2014 at 09:18 AM. Reason: More info.
18th June 2014, 04:56 PM   |  #2  
4Freedom's Avatar
Senior Member
Thanks Meter: 270
 
771 posts
Join Date:Joined: Jul 2013
More
Quote:
Originally Posted by fab0004

Hey guys, something happened to my Moto G this morning and now it won't turn on. This has happened to me previously as well where the battery drained and charging it sorted the problem out.
But this time the battery was fully charged and now it won't turn on, neither does the screen light up when I connect it to the charger (with the 0% battery logo).
Something to note - I got an update from the play store for Motorola Boot Services. My phone restarted once and showed me the new boot animation (World Cup). Then it just went dead. Not sure if this has to do something with it.
I was running stock with an unlocked bootloader, root and twrp. XT1033 dual SIM.

Any suggestions will be appreciated. Any way to at least get the phone back to stock so I can take it back to Motorola.

if u have a custom recovery u cant do system update.
i dont have your phone but remember this.
motorola release update throught playstore?

another thing could be a battery problem but idk
no recovery?no fastboot?nothing boot?
18th June 2014, 05:53 PM   |  #3  
fab0004's Avatar
OP Junior Member
Flag Mumbai
Thanks Meter: 6
 
14 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by AXD96

if u have a custom recovery u cant do system update.
i dont have your phone but remember this.
motorola release update throught playstore?

another thing could be a battery problem but idk
no recovery?no fastboot?nothing boot?

The phone just won't turn on. Not even bootloader mode. Strangely the phone feels warm as if it is being used. I'm going to let it stay and hopefully it will completely drain out and then I'll try charging it.
18th June 2014, 05:57 PM   |  #4  
Member
Thanks Meter: 16
 
40 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by fab0004

The phone just won't turn on. Not even bootloader mode. Strangely the phone feels warm as if it is being used. I'm going to let it stay and hopefully it will completely drain out and then I'll try charging it.

Try to press the power button for 120 sec, it should boot up.
18th June 2014, 06:11 PM   |  #5  
fab0004's Avatar
OP Junior Member
Flag Mumbai
Thanks Meter: 6
 
14 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by Azarielz

Try to press the power button for 120 sec, it should boot up.

Tried it. No luck. Thanks. Just wished the battery was removable
18th June 2014, 06:26 PM   |  #6  
Member
Thanks Meter: 16
 
40 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by fab0004

Tried it. No luck. Thanks. Just wished the battery was removable

Try again, with the device connected to the charger. This should perform a reset and a force boot, so it's just like removing the battery, If no luck, try to recover your bootloader by following this guide: http://forum.xda-developers.com/show....php?t=2623587
18th June 2014, 06:50 PM   |  #7  
Member
Flag Lisboa
Thanks Meter: 27
 
70 posts
Join Date:Joined: Oct 2013
More
Press power and volume down keys for about 30-45 seconds and then release. This will turn of the device and then reboot to bootloader automatically. If this doesnt work, it should be a problem with the screen.
18th June 2014, 08:37 PM   |  #8  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 74
 
312 posts
Join Date:Joined: Jun 2007
Donate to Me
More
I've updated my boot services today and it didn't cause any trouble so far.
My advice is to leave it for few hours on the charger if it's really showing the charging picture and it shows 0% there.

Post Reply Subscribe to Thread

Tags
dead, moto g, motorola boot services
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes