Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,001 Members 40,181 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Google sync not working on Kitkat

Tip us?
 
Hunnert
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2012
Default [Q] Google sync not working on Kitkat

Hi!

Been having a bit of problems with the Kitkat roms for our device,.
Both the rom and Gapps install fine in recovery (tried with both an ancient CWM, and now latest 4ext) and it boots just fine, but cannot sync with my google account. The usual menu asking if I whish to connect this device to a google account doesn't show automatically like it used to in previous android versions (only the menu to add a cyanogenmod account pops up. Tried both logging in to CM and skipping it, with identical results), and adding my Google account manually tells me it's connected, but it is unable to sync anything (cal, contacts, gmail etc) to or from my account.
Opening hangouts gives me the message "Google Play services, which some of your applications rely on, is not supported by your device", but installing the latest apk of Google Play Services manually does nothing to help.
Play store is nowhere to be found, though for example Gmail shows up like normal (but only says "Waiting for sync" when opened).

Tried Flinny's alpha 2 and 3, as well as Cyankat 1.0 and Nevergone's version as well as two different zips with Gapps. All MD5 sums checks out correctly. Full wiped several times. 4.2 works like a charm.

Has anyone else encountered this problem before? Any ideas what I can do?

Thanks!
 
fireball0093
Old
#2  
fireball0093's Avatar
Senior Member
Thanks Meter 51
Posts: 124
Join Date: Oct 2013
Location: Knox, PA
Hmm. I had something similar happen as well, though not this exact problem. I kept getting I think it was Google Play Services and something else I can't recall right now kept on FC, so nothing would sync even though it showed the little status bar sync icon. :/
Check out my HTC Desire Z/T-Mobile G2 YouTube thread Here!
Current Phone: Google Nexus 4. Android L or OmniRom.
Current ROM on HTC Desire Z: Either G2 Bliss v1.0.1, or Sensei v1.3.x
 
Hunnert
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2012
Quote:
Originally Posted by fireball0093 View Post
Hmm. I had something similar happen as well, though not this exact problem. I kept getting I think it was Google Play Services and something else I can't recall right now kept on FC, so nothing would sync even though it showed the little status bar sync icon. :/
Thanks for your reply. Can you remember what you did to resolve the problem? I'm all out of ideas here, I'll try anything! (yes I'm slightly addicted, okay? I can stop whenever I want.... )

Since yesterday I've tried to dirty flash 4.4 straight over my 4.2, without wiping first. Sync actually kept on working, but Play Store, Keep and Drive couldn't connect, although Gmail and Hangouts seemed to work as normal. I tried to dirty flash Gapps on top of this, but although sync reported that it worked, almost all Google apps FC'd immediately on opening, including Gmail and Hangouts.

Any and every idea is much appreciated!
 
popezaphod
Old
#4  
Senior Member
Thanks Meter 13
Posts: 232
Join Date: Nov 2010
Location: Oswego, NY
I am having a similar problem with the CM11 unofficial build for the LG G Pad 8.3. I appear to be the only person trying the ROM having this problem. Any advice would be appreciated.
 
Hunnert
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2012
Quote:
Originally Posted by popezaphod View Post
I am having a similar problem with the CM11 unofficial build for the LG G Pad 8.3. I appear to be the only person trying the ROM having this problem. Any advice would be appreciated.
I eventually found out that my problems were caused by having the wrong bootloader (had the one for the G2, and not the DZ in my case, they're similar but not the same) which had a systems' partition too small to accomodate Kitkat correctly, causing the problems described above. So you might want to check the size of your partitions, but I'm not at all familiar with the G Pad, so unfortunately that's all the help I'll be able to give. Best of luck, hope you'll find the problem!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes