Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Can't restore EFS[IMEI] after modem and ROM flash

OP Adooda

15th June 2014, 02:30 AM   |  #1  
OP Junior Member
Thanks Meter: 2
 
24 posts
Join Date:Joined: Feb 2013
I have E971
So I was back to STOCK with Rogers 4.0.4 then rooted
then I flashed Paulicat ported kitkat I didn't have wifi so I flashed a jellybean modem as he said
I lost IMEI started showing NULL after dialing *#06#
I have the EFS files on my pc I restored them with FreeGee I still get NULL but when I take out the SIM card I can see the correct IMEI
I flashed the ZEROS EFS and I could see that IMEI is 000000000 however I can't with the backuped EFS files (img)
I also tried with terminal emulator but didn't help



any help on how getting the EFS restored back correctly?
can someone help me make a zip file for my EFS files?
18th June 2014, 08:46 AM   |  #2  
akiscoolio's Avatar
Member
Thanks Meter: 1
 
42 posts
Join Date:Joined: Jul 2008
Try to install the official rom that you took the efs back up with,and then flash efs back up
18th June 2014, 03:25 PM   |  #3  
Ahmed Xperia p's Avatar
Senior Member
Flag Islamabad
Thanks Meter: 56
 
299 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by Adooda

I have E971
So I was back to STOCK with Rogers 4.0.4 then rooted
then I flashed Paulicat ported kitkat I didn't have wifi so I flashed a jellybean modem as he said
I lost IMEI started showing NULL after dialing *#06#
I have the EFS files on my pc I restored them with FreeGee I still get NULL but when I take out the SIM card I can see the correct IMEI
I flashed the ZEROS EFS and I could see that IMEI is 000000000 however I can't with the backuped EFS files (img)
I also tried with terminal emulator but didn't help



any help on how getting the EFS restored back correctly?
can someone help me make a zip file for my EFS files?

What procedure you are using for restore?
20th June 2014, 01:49 AM   |  #4  
OP Junior Member
Thanks Meter: 2
 
24 posts
Join Date:Joined: Feb 2013
Thumbs up
I solved it thanks guys I needed to flash the right modem and it's done now
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes