Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q]/system r/w mount problem (ric)

OP gongzhen

16th June 2014, 03:03 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2011
I've rooted my z1c with locked bootloader and install a rom after wiped /system. But /system cannot be mounted as r/w. I've flashed dualrecovery again while it did not work.
Nothing is in /sys/kernel/security/sony_ric/ and /sbin/ric cannot be deleted after I executed /system/xbin/rickiller.sh
How can i solve it? Is is a problem caused by rom and which file is missing? Or will it be solved after unlocking bootloader and flash another kernel?
Please help.

Sent from my D5503 using XDA Premium 4 mobile app
17th June 2014, 09:40 AM   |  #2  
zxz0O0's Avatar
Senior Member
Thanks Meter: 1,436
 
922 posts
Join Date:Joined: Apr 2011
Donate to Me
More
You can't simply execute the script, it needs to be executed at boot before RIC is intialized. I advise you to flash stock rom with flashtool (for clean /system) then simply root with this tool: http://forum.xda-developers.com/show....php?t=2784900 and install dualrecovery again.
The Following 2 Users Say Thank You to zxz0O0 For This Useful Post: [ View ]
20th June 2014, 04:27 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by zxz0O0

You can't simply execute the script, it needs to be executed at boot before RIC is intialized. I advise you to flash stock rom with flashtool (for clean /system) then simply root with this tool: http://forum.xda-developers.com/show....php?t=2784900 and install dualrecovery again.

Thx. It works. It seems that installmount.sh in the new root tool enables the r/w permission.

Sent from my D5503 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes