FORUMS

Xperia SP boot only when 100% battery (or connected to usb)

1 posts
Thanks Meter: 0
 
By johnnyjjohnson, Junior Member on 20th June 2014, 01:43 AM
Post Reply Subscribe to Thread Email Thread
Hi, i own a sony xperia sp and have a big problem: my phone works perfectly only when connected to usb or charge.

When the phone is off and i try to turn it up it will boot to OS only if the battery is at 100%. if it's not 100% the phone will try to boot but will crash at some point.
but as said before if i power it up while connected to usb or charge the phone will boot normally and will work fine. by the way even if i can boot, when i disconnect the cable the phone will crash and shut down after some time.

i' ve checked the battery status and it says Good, no need to replace it. uAh: 2367000.
i've tried to wipe data, upgrade\downgrade firmware but nothing worked.

May someone help me with this?
Last edited by johnnyjjohnson; 20th June 2014 at 01:50 AM.
 
 
20th June 2014, 04:08 PM |#2  
jackaros's Avatar
Senior Member
Flag Kavala
Thanks Meter: 169
 
Donate to Me
More
Quote:
Originally Posted by johnnyjjohnson

Hi, i own a sony xperia sp and have a big problem: my phone works perfectly only when connected to usb or charge.

When the phone is off and i try to turn it up it will boot to OS only if the battery is at 100%. if it's not 100% the phone will try to boot but will crash at some point.
but as said before if i power it up while connected to usb or charge the phone will boot normally and will work fine. by the way even if i can boot, when i disconnect the cable the phone will crash and shut down after some time.

i' ve checked the battery status and it says Good, no need to replace it. uAh: 2367000.
i've tried to wipe data, upgrade\downgrade firmware but nothing worked.

May someone help me with this?

My guess : Kernel problem if its not a kernel thing then your hardware has problems
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes