Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,266 Members 41,814 Now Online
XDA Developers Android and Mobile Development Forum

[solved] Andriod upgrading everytime when restarts

Tip us?
 
ananthtcr
Old
(Last edited by ananthtcr; 20th May 2014 at 09:34 AM.)
#1  
ananthtcr's Avatar
Member - OP
Thanks Meter 46
Posts: 52
Join Date: Apr 2014
Location: TUTICORIN
Default [solved] Andriod upgrading everytime when restarts

Today im Updated 4.3 JB in my Xperia M Dual using SUS...

update was completed successfully...

but everytime when i switch on my mobile it showing,


Andriod is upgrading...

Starting Applications...


What is this?? this is really happen in all mobile or is this any error??

if it is a problem then, how to fix this problem...

Help me experts.....

 
elmkzgirxp
Old
#2  
elmkzgirxp's Avatar
Senior Member
Thanks Meter 29
Posts: 238
Join Date: May 2013
Try resetting it with SUS and see if it works.
 
theperson333
Old
#3  
Member
Thanks Meter 15
Posts: 88
Join Date: Nov 2012
IIRC, this means android is making new dalvik cache for the apps or the one it has on the phone is old version.

This could indicate problem at \cache\

Try a file explorer. post screenshot of what you see.
Devices
Xperia m c1905(a perfect companion for mn2)

Samsung Galaxy mini

SmartWatch(mn2)

Nokia 6500


Instead of typing thanks, why not press thanks if I helped you?
The Following User Says Thank You to theperson333 For This Useful Post: [ Click to Expand ]
 
ananthtcr
Old
#4  
ananthtcr's Avatar
Member - OP
Thanks Meter 46
Posts: 52
Join Date: Apr 2014
Location: TUTICORIN
Quote:
Originally Posted by theperson333 View Post
IIRC, this means android is making new dalvik cache for the apps or the one it has on the phone is old version.

This could indicate problem at \cache\

Try a file explorer. post screenshot of what you see.

Bro, there is no folder like /cache in my internal and external card...
Pls tell me, the correct path, i will show you immediately...
But, remember one thing my mobile is a rooted one before doing 4.3 update.. Is that the reason for this problem???
Give ans bro..
 
mbc07
Old
#5  
mbc07's Avatar
Senior Member
Thanks Meter 392
Posts: 365
Join Date: Dec 2013
Try resetting your dalvik-cache... Use a file explorer with root access or adb shell and delete the folder dalvik-cache found inside /data (or rm -r -f /data/dalvik-cache from adb shell). Right after that you should reboot your phone (after deleting that folder all apps will start FCing, it's ok). In the next reboot the "Android is upgrading" screen will show and will take some time since it'll regenerate the cache. This should fix your problem.

If even after resetting dalvik-cache the same thing keep occurring, then inside /system/app you may have an .odex file for an .apk that contains classes.dex inside (e.g. you have an .odex for an APK that already is deodexed). It's common to occur when using apps like Lucky Patcher to apply patches or apps like Titanium Backup that allow integrating dalvik cache of apps inside system partition...
Sony Xperia M dual [C2004]
ROM: 15.5.A.1.5 (stock)
Android version: 4.3 (rooted)
Bootloader: locked (unlockable)
The Following User Says Thank You to mbc07 For This Useful Post: [ Click to Expand ]
 
ananthtcr
Old
#6  
ananthtcr's Avatar
Member - OP
Thanks Meter 46
Posts: 52
Join Date: Apr 2014
Location: TUTICORIN
Quote:
Originally Posted by mbc07 View Post
Try resetting your dalvik-cache... Use a file explorer with root access or adb shell and delete the folder dalvik-cache found inside /data (or rm -r -f /data/dalvik-cache from adb shell). Right after that you should reboot your phone (after deleting that folder all apps will start FCing, it's ok). In the next reboot the "Android is upgrading" screen will show and will take some time since it'll regenerate the cache. This should fix your problem.

If even after resetting dalvik-cache the same thing keep occurring, then inside /system/app you may have an .odex file for an .apk that contains classes.dex inside (e.g. you have an .odex for an APK that already is deodexed). It's common to occur when using apps like Lucky Patcher to apply patches or apps like Titanium Backup that allow integrating dalvik cache of apps inside system partition...
Thanks for ur response bro...

my root access is gone after the update..
now i cant able to use titanium backup or file explorer with root access..
 
mbc07
Old
#7  
mbc07's Avatar
Senior Member
Thanks Meter 392
Posts: 365
Join Date: Dec 2013
Quote:
Originally Posted by ananthtcr View Post
Thanks for ur response bro...

my root access is gone after the update..
now i cant able to use titanium backup or file explorer with root access..
If you updated without wiping data and cache it's very likely to be the cause of this problem, while you had root access one of those apps may have changed something in dalvik-cache and now that you don't have root access anymore Android keeps trying to "optimize" that app every time the phone boots...
Sony Xperia M dual [C2004]
ROM: 15.5.A.1.5 (stock)
Android version: 4.3 (rooted)
Bootloader: locked (unlockable)
 
ananthtcr
Old
(Last edited by ananthtcr; 20th May 2014 at 09:33 AM.)
#8  
ananthtcr's Avatar
Member - OP
Thanks Meter 46
Posts: 52
Join Date: Apr 2014
Location: TUTICORIN
Problem fixed!!!!!

I uninstall some apps which needs root acces and successfully deleted data/cache folder (Which is in hidden state earlier).
Now the Android Upgrading msg not coming..


Thanks Experts!!! You are really Great!!!

Specially thank to theperson333 and mbc07
 
55pawan
Old
#9  
55pawan's Avatar
Junior Member
Thanks Meter 0
Posts: 20
Join Date: Jun 2013
Default android is upgrading on boot up

i did the above steps
wiped dalvik cache using cwm recovery
bt still problem persist
on boot up it show android is upgrading...
lemme tell what exactly happened from beginning
im using xperia l(4.2.2) with root access
i installed a keyboard ported from 4.4 to all xperia running jb.(for that i mounted system n flashed the zip using cwm recovery)
n keyboard is working fine bt problem is that
on every boot up
xl shows android is upgrading n takes 5 min to start..
i even searced for. dex app in system bt there is no app with that extension..

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Google Play Store 4.9 Brings New, Image-Rich UI with a Hint of Material Design

It’s not Wednesday yet, but we’ve got a great … more

Remove Unnecessary WhatsApp Elements with Xposed

In modern life, you can’t underestimate the power ofthe dark sidemessaging … more

MaR-V-iN to Talk Google and Android APIs at XDA:DevCon 2014

Our international xda:devcon 14in Manchester, UK on the weekend of September … more

But First, Let Me Take a #Selfie

“Today while browsing XDA,I’m going tocheck to seeif my favorite ROM has been updated–but … more