Top 5 Apps for 2014 + Top Xposed Mod of 2014 – XDA TV

Its that time of year where you look back and remember the things that happened … more

NVIDIA SHIELD Tablet Gets Android 5.0.1, OTA Available

The NVIDIA SHIELD Tablet is the latest Android-powered device released by famed GPU … more

FXP Team Delivers Lollipop to Various Xperia Devices!

From all of us here at XDA-Developers, we’d like to wish you Happy Holidays! If … more

Turn Your Camera Into a Live Puzzle Game

The classic sliding puzzle game hasnt changed much, if at all, over the years. Dating all the way … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[solved] Andriod upgrading everytime when restarts

OP ananthtcr

19th May 2014, 09:19 AM   |  #1  
ananthtcr's Avatar
OP Member
Flag Thoothukkudi
Thanks Meter: 79
 
84 posts
Join Date:Joined: Apr 2014
More
Today im Updated 4.3 JB in my Xperia M Dual using SUS...

update was completed successfully...

but everytime when i switch on my mobile it showing,


Andriod is upgrading...

Starting Applications...


What is this?? this is really happen in all mobile or is this any error??

if it is a problem then, how to fix this problem...

Help me experts.....

Last edited by ananthtcr; 20th May 2014 at 10:34 AM.
19th May 2014, 03:18 PM   |  #2  
elmkzgirxp's Avatar
Senior Member
Thanks Meter: 44
 
303 posts
Join Date:Joined: May 2013
More
Try resetting it with SUS and see if it works.
19th May 2014, 06:04 PM   |  #3  
theperson333's Avatar
Senior Member
Thanks Meter: 27
 
129 posts
Join Date:Joined: Nov 2012
More
IIRC, this means android is making new dalvik cache for the apps or the one it has on the phone is old version.

This could indicate problem at \cache\

Try a file explorer. post screenshot of what you see.
The Following User Says Thank You to theperson333 For This Useful Post: [ View ]
20th May 2014, 04:35 AM   |  #4  
ananthtcr's Avatar
OP Member
Flag Thoothukkudi
Thanks Meter: 79
 
84 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by theperson333

IIRC, this means android is making new dalvik cache for the apps or the one it has on the phone is old version.

This could indicate problem at \cache\

Try a file explorer. post screenshot of what you see.


Bro, there is no folder like /cache in my internal and external card...
Pls tell me, the correct path, i will show you immediately...
But, remember one thing my mobile is a rooted one before doing 4.3 update.. Is that the reason for this problem???
Give ans bro..
20th May 2014, 07:21 AM   |  #5  
mbc07's Avatar
Senior Member
Thanks Meter: 449
 
402 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Try resetting your dalvik-cache... Use a file explorer with root access or adb shell and delete the folder dalvik-cache found inside /data (or rm -r -f /data/dalvik-cache from adb shell). Right after that you should reboot your phone (after deleting that folder all apps will start FCing, it's ok). In the next reboot the "Android is upgrading" screen will show and will take some time since it'll regenerate the cache. This should fix your problem.

If even after resetting dalvik-cache the same thing keep occurring, then inside /system/app you may have an .odex file for an .apk that contains classes.dex inside (e.g. you have an .odex for an APK that already is deodexed). It's common to occur when using apps like Lucky Patcher to apply patches or apps like Titanium Backup that allow integrating dalvik cache of apps inside system partition...
The Following User Says Thank You to mbc07 For This Useful Post: [ View ]
20th May 2014, 07:54 AM   |  #6  
ananthtcr's Avatar
OP Member
Flag Thoothukkudi
Thanks Meter: 79
 
84 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by mbc07

Try resetting your dalvik-cache... Use a file explorer with root access or adb shell and delete the folder dalvik-cache found inside /data (or rm -r -f /data/dalvik-cache from adb shell). Right after that you should reboot your phone (after deleting that folder all apps will start FCing, it's ok). In the next reboot the "Android is upgrading" screen will show and will take some time since it'll regenerate the cache. This should fix your problem.

If even after resetting dalvik-cache the same thing keep occurring, then inside /system/app you may have an .odex file for an .apk that contains classes.dex inside (e.g. you have an .odex for an APK that already is deodexed). It's common to occur when using apps like Lucky Patcher to apply patches or apps like Titanium Backup that allow integrating dalvik cache of apps inside system partition...

Thanks for ur response bro...

my root access is gone after the update..
now i cant able to use titanium backup or file explorer with root access..
20th May 2014, 08:16 AM   |  #7  
mbc07's Avatar
Senior Member
Thanks Meter: 449
 
402 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Quote:
Originally Posted by ananthtcr

Thanks for ur response bro...

my root access is gone after the update..
now i cant able to use titanium backup or file explorer with root access..

If you updated without wiping data and cache it's very likely to be the cause of this problem, while you had root access one of those apps may have changed something in dalvik-cache and now that you don't have root access anymore Android keeps trying to "optimize" that app every time the phone boots...
20th May 2014, 10:27 AM   |  #8  
ananthtcr's Avatar
OP Member
Flag Thoothukkudi
Thanks Meter: 79
 
84 posts
Join Date:Joined: Apr 2014
More
Problem fixed!!!!!

I uninstall some apps which needs root acces and successfully deleted data/cache folder (Which is in hidden state earlier).
Now the Android Upgrading msg not coming..


Thanks Experts!!! You are really Great!!!

Specially thank to theperson333 and mbc07
Last edited by ananthtcr; 20th May 2014 at 10:33 AM.
21st June 2014, 05:19 PM   |  #9  
55pawan's Avatar
Senior Member
Flag new delhi
Thanks Meter: 14
 
102 posts
Join Date:Joined: Jun 2013
More
android is upgrading on boot up
i did the above steps
wiped dalvik cache using cwm recovery
bt still problem persist
on boot up it show android is upgrading...
lemme tell what exactly happened from beginning
im using xperia l(4.2.2) with root access
i installed a keyboard ported from 4.4 to all xperia running jb.(for that i mounted system n flashed the zip using cwm recovery)
n keyboard is working fine bt problem is that
on every boot up
xl shows android is upgrading n takes 5 min to start..
i even searced for. dex app in system bt there is no app with that extension..

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes