FORUMS

[Q] strange battery drain, overheating with no wakelocks

2 posts
Thanks Meter: 0
 
By mamdoj, Junior Member on 21st June 2014, 03:59 PM
Post Reply Subscribe to Thread Email Thread
Hi! sorry about my English.

I'm having a strange problem with my exynos galaxy s5. It sometimes gets really hot and the battery drains really fast, even with low usage (emails and whatsapp). It's definitely a software problem, because it disappears on reboot. But after a while it returns.

After a reboot i can get sometimes 4.5h to 5h or more of screen on time with no overheating, full day, but than something triggers and i have 2.5 screen or 3h max on with a hot device on wifi, and terrible standby time.

I can't pinpoint the problem. It's not a wakelock problem. I Checked wakelock detector (PC version, since my device is unrooted), and it shows only 8% wake on a full day (yesterday).
The battery on setting shows normal usage: the screen is always on top, followed by android os.

I really don't know what to do, besides keeping rebooting the device every day. No luck turning locations services off.
 
 
21st June 2014, 05:19 PM |#2  
Senior Member
Thanks Meter: 8
 
More
Check if the weather thing is using GPS. I found out that in places with poor GPS reception, the lock screen weather widget can keep GPS running forever until it gets a fix.
21st June 2014, 05:20 PM |#3  
Senior Member
Thanks Meter: 879
 
More
Quote:
Originally Posted by mamdoj

Hi! sorry about my English.

I'm having a strange problem with my exynos galaxy s5. It sometimes gets really hot and the battery drains really fast, even with low usage (emails and whatsapp). It's definitely a software problem, because it disappears on reboot. But after a while it returns.

After a reboot i can get sometimes 4.5h to 5h or more of screen on time with no overheating, full day, but than something triggers and i have 2.5 screen or 3h max on with a hot device on wifi, and terrible standby time.

I can't pinpoint the problem. It's not a wakelock problem. I Checked wakelock detector (PC version, since my device is unrooted), and it shows only 8% wake on a full day (yesterday).
The battery on setting shows normal usage: the screen is always on top, followed by android os.

I really don't know what to do, besides keeping rebooting the device every day. No luck turning locations services off.

Your English is very good.

I would do a full wipe.

What software version do you currently have?

Sent from my SM-G900H using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes