Android One Expanding to Bangladesh, Nepal, and Sri Lanka

At Google I/O 2013, Google proudly announced that the Android operating system was … more

Android 5.0.2 Fixes 2012 Nexus 7! Sony’s Making a Google Glass Competitor? – XDA TV

Android 5.0.2 Lollipop is available for the … more

Early Lollipop Ports for Micromax A116 and A117

It feels like it was only yesterday when Google announced the mysterious Android L.After … more

Now Gesture Tweaks Replaces Google Now with Custom Action

On most modern Android devices with software navigation keys, swiping up from the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Problem flashing certain things using TWRP

OP DCVR 614

21st June 2014, 11:10 PM   |  #1  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
58 posts
Join Date:Joined: Feb 2009
More
I was just on the MJ9 firmware had no problem flashing other roms using TWRP. I read that TWRP was having issues flashing ND7 and seen that using Philz was the best thing to use, so I downloaded Philz and saved it, uploaded it to my external SD card along with the other required files for ND7. Rebooted to the recovery formatted the internal storage,dalvik and cache. First thing I did was try to install Philz. I instantly got failed and this message "assert failed: getprop (ro.product.device") I thought it had something to do with the Kitkat update. But, then I read on the forum that one user was having trouble installing Philz also and the user installed the ND7 first then Philz and it installed. So, I decided to try that. The update installed just fine but Philz still gave me the same error. I decided to try to install the radio that gave me the same error. I already had Liquid smooth 4.4 downloaded on my SD card and that wouldn't flash either but the gapps installed. I have installed the newest version of TWRP still no luck. I can't even use Airdroid to transfer to either SD card or internal storage (Later found out its an app problem). What else can I do to get the ball rolling?
Attached Files
File Type: txt recovery.txt - [Click for QR Code] (13.3 KB, 3 views)
21st June 2014, 11:20 PM   |  #2  
gr8nole's Avatar
Recognized Contributor
Lynchburg, VA
Thanks Meter: 3,911
 
2,543 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by DCVR 614

I was just on the MJ9 firmware had no problem flashing other roms using TWRP. I read that TWRP was having issues flashing ND7 and seen that using Philz was the best thing to use, so I downloaded Philz and saved it, uploaded it to my external SD card along with the other required files for ND7. Rebooted to the recovery formatted the internal storage,dalvik and cache. First thing I did was try to install Philz. I instantly got failed and this message "assert failed: getprop (ro.product.device") I thought it had something to do with the Kitkat update. But, then I read on the forum that one user was having trouble installing Philz also and the user installed the ND7 first then Philz and it installed. So, I decided to try that. The update installed just fine but Philz still gave me the same error. I decided to try to install the radio that gave me the same error. I already had Liquid smooth 4.4 downloaded on my SD card and that wouldn't flash either but the gapps installed. I have installed the newest version of TWRP still no luck. I can't even use Airdroid to transfer to either SD card or internal storage (Later found out its an app problem). What else can I do to get the ball rolling?

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.
Attached Files
File Type: zip philz_touch_6.41.6-i605.zip - [Click for QR Code] (6.89 MB, 15 views)
21st June 2014, 11:33 PM   |  #3  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
58 posts
Join Date:Joined: Feb 2009
More
Quote:
Originally Posted by gr8nole

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.

That installed and worked. The ND7 Radio also installed. How do I fix the getprop asserts?
Last edited by DCVR 614; 21st June 2014 at 11:36 PM.
21st June 2014, 11:53 PM   |  #4  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
58 posts
Join Date:Joined: Feb 2009
More
Quote:
Originally Posted by gr8nole

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.

Okay, I got liquid smooth installed along with the gapps. Thank you for all your help. What can I do to get this get props corrected?
21st June 2014, 11:55 PM   |  #5  
gr8nole's Avatar
Recognized Contributor
Lynchburg, VA
Thanks Meter: 3,911
 
2,543 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by DCVR 614

Okay, I got liquid smooth installed along with the gapps. Thank you for all your help. What can I do to get this get props corrected?

It is already fixed now that you have a proper i605 recovery installed.

Sent from my SCH-I605
22nd June 2014, 12:04 AM   |  #6  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
58 posts
Join Date:Joined: Feb 2009
More
Quote:
Originally Posted by gr8nole

It is already fixed now that you have a proper i605 recovery installed.

Sent from my SCH-I605

OH! Thank you so much. I appreciate your help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes