FORUMS

Android M Code Name: Macadamia Nut Cookie

While the official name for the latest iteration of Android has yet to be revealed, the code … more

XDA Recap: This Week In Android (May 17 – 23)

Another week, another recap. The Sunday tradition marches on this week with a fresh … more

Huawei To Sell Honor Smartphones Via Indian Retail Outlets

World’s fourth largest smartphone maker Huawei plans to now sell its … more

Sunday Debate: Are Smaller Bezels Better or Worth It?

Bezels have been getting smaller and smaller as the years go by, and while devices … more
Post Reply Subscribe to Thread Email Thread

[Q] Problem flashing certain things using TWRP

21st June 2014, 10:10 PM |#1  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
More
I was just on the MJ9 firmware had no problem flashing other roms using TWRP. I read that TWRP was having issues flashing ND7 and seen that using Philz was the best thing to use, so I downloaded Philz and saved it, uploaded it to my external SD card along with the other required files for ND7. Rebooted to the recovery formatted the internal storage,dalvik and cache. First thing I did was try to install Philz. I instantly got failed and this message "assert failed: getprop (ro.product.device") I thought it had something to do with the Kitkat update. But, then I read on the forum that one user was having trouble installing Philz also and the user installed the ND7 first then Philz and it installed. So, I decided to try that. The update installed just fine but Philz still gave me the same error. I decided to try to install the radio that gave me the same error. I already had Liquid smooth 4.4 downloaded on my SD card and that wouldn't flash either but the gapps installed. I have installed the newest version of TWRP still no luck. I can't even use Airdroid to transfer to either SD card or internal storage (Later found out its an app problem). What else can I do to get the ball rolling?
Attached Files
File Type: txt recovery.txt - [Click for QR Code] (13.3 KB, 7 views)
 
 
21st June 2014, 10:20 PM |#2  
gr8nole's Avatar
Recognized Contributor
Lynchburg, VA
Thanks Meter: 4,366
 
Donate to Me
More
Quote:
Originally Posted by DCVR 614

I was just on the MJ9 firmware had no problem flashing other roms using TWRP. I read that TWRP was having issues flashing ND7 and seen that using Philz was the best thing to use, so I downloaded Philz and saved it, uploaded it to my external SD card along with the other required files for ND7. Rebooted to the recovery formatted the internal storage,dalvik and cache. First thing I did was try to install Philz. I instantly got failed and this message "assert failed: getprop (ro.product.device") I thought it had something to do with the Kitkat update. But, then I read on the forum that one user was having trouble installing Philz also and the user installed the ND7 first then Philz and it installed. So, I decided to try that. The update installed just fine but Philz still gave me the same error. I decided to try to install the radio that gave me the same error. I already had Liquid smooth 4.4 downloaded on my SD card and that wouldn't flash either but the gapps installed. I have installed the newest version of TWRP still no luck. I can't even use Airdroid to transfer to either SD card or internal storage (Later found out its an app problem). What else can I do to get the ball rolling?

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.
Attached Files
File Type: zip philz_touch_6.41.6-i605.zip - [Click for QR Code] (6.89 MB, 17 views)
21st June 2014, 10:33 PM |#3  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
More
Quote:
Originally Posted by gr8nole

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.

That installed and worked. The ND7 Radio also installed. How do I fix the getprop asserts?
Last edited by DCVR 614; 21st June 2014 at 10:36 PM.
21st June 2014, 10:53 PM |#4  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
More
Quote:
Originally Posted by gr8nole

Seems like you still have the wrong TWRP for your device.

Here is a Philz Zip with the getprop asserts removed, so it should flash just fine in your current TWRP.

Okay, I got liquid smooth installed along with the gapps. Thank you for all your help. What can I do to get this get props corrected?
21st June 2014, 10:55 PM |#5  
gr8nole's Avatar
Recognized Contributor
Lynchburg, VA
Thanks Meter: 4,366
 
Donate to Me
More
Quote:
Originally Posted by DCVR 614

Okay, I got liquid smooth installed along with the gapps. Thank you for all your help. What can I do to get this get props corrected?

It is already fixed now that you have a proper i605 recovery installed.

Sent from my SCH-I605
21st June 2014, 11:04 PM |#6  
DCVR 614's Avatar
OP Member
Columbus
Thanks Meter: 4
 
More
Quote:
Originally Posted by gr8nole

It is already fixed now that you have a proper i605 recovery installed.

Sent from my SCH-I605

OH! Thank you so much. I appreciate your help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes